summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-10-13 23:54:59 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-10-13 23:54:59 +0000
commitcfa09263f62e3f673f615d59ca4915f17a84af98 (patch)
tree47de9548ec62edb487359c3ba1162bbcfc72475f /app-text/rnv
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-cfa09263f62e3f673f615d59ca4915f17a84af98.tar.gz
gentoo-2-cfa09263f62e3f673f615d59ca4915f17a84af98.tar.bz2
gentoo-2-cfa09263f62e3f673f615d59ca4915f17a84af98.zip
respect CFLAGS, reported on bug 240140 by flameeyes
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-text/rnv')
-rw-r--r--app-text/rnv/ChangeLog9
-rw-r--r--app-text/rnv/files/rnv-1.7.8-respect-CFLAGS.patch20
-rw-r--r--app-text/rnv/rnv-1.7.8-r2.ebuild (renamed from app-text/rnv/rnv-1.7.8-r1.ebuild)10
3 files changed, 37 insertions, 2 deletions
diff --git a/app-text/rnv/ChangeLog b/app-text/rnv/ChangeLog
index f87cd31ce1e6..77f4477a0b5d 100644
--- a/app-text/rnv/ChangeLog
+++ b/app-text/rnv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/rnv
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rnv/ChangeLog,v 1.5 2008/06/11 16:34:36 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rnv/ChangeLog,v 1.6 2008/10/13 23:54:59 opfer Exp $
+
+*rnv-1.7.8-r2 (13 Oct 2008)
+
+ 13 Oct 2008; Christian Faulhammer <opfer@gentoo.org>
+ +files/rnv-1.7.8-respect-CFLAGS.patch, -rnv-1.7.8-r1.ebuild,
+ +rnv-1.7.8-r2.ebuild:
+ respect CFLAGS, reported on bug 240140 by flameeyes
11 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org> rnv-1.7.8-r1.ebuild:
Added ~ppc, bug #213008
diff --git a/app-text/rnv/files/rnv-1.7.8-respect-CFLAGS.patch b/app-text/rnv/files/rnv-1.7.8-respect-CFLAGS.patch
new file mode 100644
index 000000000000..85ef49e8619f
--- /dev/null
+++ b/app-text/rnv/files/rnv-1.7.8-respect-CFLAGS.patch
@@ -0,0 +1,20 @@
+--- Makefile.gnu.orig 2006-11-02 09:54:08.000000000 +0100
++++ Makefile.gnu 2008-10-14 01:45:25.000000000 +0200
+@@ -26,7 +26,7 @@
+ WARN=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wcast-align
+ OPT=-O -g
+
+-CFLAGS=${INC} ${DEF} ${WARN} ${OPT}
++CLAGS=${INC} ${DEF} ${WARN} ${OPT} ${CFLAGS}
+ LFLAGS=${OPT} ${LBL}
+
+ LIBEXPAT=-lexpat
+@@ -106,7 +106,7 @@
+ .SUFFIXES: .c .o
+
+ .c.o:
+- ${CC} ${CFLAGS} -c -o $@ $<
++ ${CC} ${CLAGS} -c -o $@ $<
+
+ all: rnv arx rvp xsdck test
+
diff --git a/app-text/rnv/rnv-1.7.8-r1.ebuild b/app-text/rnv/rnv-1.7.8-r2.ebuild
index d33444eb3363..ad5e9822a717 100644
--- a/app-text/rnv/rnv-1.7.8-r1.ebuild
+++ b/app-text/rnv/rnv-1.7.8-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rnv/rnv-1.7.8-r1.ebuild,v 1.4 2008/06/11 16:34:36 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rnv/rnv-1.7.8-r2.ebuild,v 1.1 2008/10/13 23:54:59 opfer Exp $
+
+inherit eutils
DESCRIPTION="A lightweight Relax NG Compact Syntax validator"
HOMEPAGE="http://www.davidashen.net/rnv.html"
@@ -15,6 +17,12 @@ RDEPEND="dev-libs/expat"
DEPEND="${RDEPEND}
app-arch/unzip"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-respect-CFLAGS.patch"
+}
+
src_compile() {
emake -j1 -f Makefile.gnu || die
}