summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Allanos <dju@gentoo.org>2007-01-08 14:17:25 +0000
committerJulien Allanos <dju@gentoo.org>2007-01-08 14:17:25 +0000
commit54fe626ad0924db71b41f48c53d068177d31f741 (patch)
treeac128b44bcfd81eb290028e337fafce0d0cb5053 /app-text/silvercity/silvercity-0.9.7.ebuild
parentOops, forgot the keyword.. (diff)
downloadgentoo-2-54fe626ad0924db71b41f48c53d068177d31f741.tar.gz
gentoo-2-54fe626ad0924db71b41f48c53d068177d31f741.tar.bz2
gentoo-2-54fe626ad0924db71b41f48c53d068177d31f741.zip
Version bump to 0.9.7. Removed 0.9.6.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-text/silvercity/silvercity-0.9.7.ebuild')
-rw-r--r--app-text/silvercity/silvercity-0.9.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/silvercity/silvercity-0.9.7.ebuild b/app-text/silvercity/silvercity-0.9.7.ebuild
new file mode 100644
index 000000000000..6257c0830bbc
--- /dev/null
+++ b/app-text/silvercity/silvercity-0.9.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/silvercity-0.9.7.ebuild,v 1.1 2007/01/08 14:17:25 dju Exp $
+
+inherit distutils eutils python
+
+DESCRIPTION="A lexical analyser for many languages."
+HOMEPAGE="http://silvercity.sourceforge.net/"
+
+MY_P=${P/silvercity/SilverCity}
+SRC_URI="mirror://sourceforge/silvercity/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+
+src_install() {
+ distutils_src_install
+
+ # remove useless documentation
+ rm ${D}/usr/share/doc/${P}/PKG-INFO.gz
+
+ # fix permissions
+ python_version
+ chmod 644 ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/SilverCity/default.css
+
+ # fix CR/LF issue
+ find ${D}/usr/bin -iname "*.py" -exec sed -e 's/\r$//' -i \{\} \;
+
+ # fix path
+ dosed -i 's|#!/usr/home/sweetapp/bin/python|#!/usr/bin/env python|' \
+ /usr/bin/cgi-styler-form.py || die "dosed failed"
+}