summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-14 06:18:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-14 06:18:40 +0000
commitb06661ba29b218b7f62b2e5e5e5a053d4d644514 (patch)
tree30aaa924a4d938aaae5ff4a7f36f880758516ced /app-text/texi2html/texi2html-5.0.ebuild
parentKeyword ~ppc/~ppc64 for app-text/texi2html. (diff)
downloadgentoo-2-b06661ba29b218b7f62b2e5e5e5a053d4d644514.tar.gz
gentoo-2-b06661ba29b218b7f62b2e5e5e5a053d4d644514.tar.bz2
gentoo-2-b06661ba29b218b7f62b2e5e5e5a053d4d644514.zip
Version bump wrt #258998 by Arfrever Frehtes Taifersar Arahesis
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-text/texi2html/texi2html-5.0.ebuild')
-rw-r--r--app-text/texi2html/texi2html-5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/texi2html/texi2html-5.0.ebuild b/app-text/texi2html/texi2html-5.0.ebuild
new file mode 100644
index 000000000000..3ad59ca76ef0
--- /dev/null
+++ b/app-text/texi2html/texi2html-5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/texi2html/texi2html-5.0.ebuild,v 1.1 2012/03/14 06:18:40 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="Perl script that converts Texinfo to HTML"
+HOMEPAGE="http://www.nongnu.org/texi2html/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.bz2"
+
+LICENSE="CCPL-ShareAlike-1.0 FDL-1.3 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="unicode"
+
+RDEPEND=">=dev-lang/perl-5.10.1
+ dev-perl/libintl-perl
+ unicode? ( dev-perl/Text-Unidecode )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_configure() {
+ econf \
+ --with-external-libintl-perl \
+ $(use_with unicode unidecode)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README}
+}
+
+pkg_preinst() {
+ rm -f "${EROOT}"/usr/bin/${PN}
+}