summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2004-09-05 11:50:44 +0000
committerMalcolm Lashley <malc@gentoo.org>2004-09-05 11:50:44 +0000
commit884111129bd53e11d77870c4c9392a80279f7b89 (patch)
treea14fc98e06e1178f8883cd854d9e816193deb7eb /app-text/wdiff/wdiff-0.5-r2.ebuild
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-884111129bd53e11d77870c4c9392a80279f7b89.tar.gz
gentoo-2-884111129bd53e11d77870c4c9392a80279f7b89.tar.bz2
gentoo-2-884111129bd53e11d77870c4c9392a80279f7b89.zip
Keyworded ~amd64 and applied avoid-wraps patch - bug #62456
Diffstat (limited to 'app-text/wdiff/wdiff-0.5-r2.ebuild')
-rw-r--r--app-text/wdiff/wdiff-0.5-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/wdiff/wdiff-0.5-r2.ebuild b/app-text/wdiff/wdiff-0.5-r2.ebuild
new file mode 100644
index 000000000000..1da932c7680e
--- /dev/null
+++ b/app-text/wdiff/wdiff-0.5-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/wdiff-0.5-r2.ebuild,v 1.1 2004/09/05 11:50:44 malc Exp $
+
+inherit eutils
+
+IUSE="build"
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="http://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~mips ~ppc ~amd64"
+
+DEPEND="sys-libs/libtermcap-compat
+ sys-apps/diffutils
+ sys-apps/less"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-segfault-fix.diff
+ epatch ${FILESDIR}/${P}-avoid-wraps.diff
+}
+
+src_compile() {
+ # Cannot use econf here because the configure script that
+ # comes with wdiff is too old to understand the standard
+ # options.
+
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ if ! use build
+ then
+ dodoc COPYING ChangeLog NEWS README
+ doman wdiff.1
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+}