summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-06 22:05:09 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-06 22:05:09 +0000
commitd286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f (patch)
treeeb20968f2bea31b2735bf561261d7c825c4fdb30 /app-text/wdiff/wdiff-0.5-r3.ebuild
parentUnbundling speex and zlib. Partially fix bug #255453 (diff)
downloadgentoo-2-d286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f.tar.gz
gentoo-2-d286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f.tar.bz2
gentoo-2-d286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f.zip
Fix for bug 301171, ignore case patch
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-text/wdiff/wdiff-0.5-r3.ebuild')
-rw-r--r--app-text/wdiff/wdiff-0.5-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/wdiff/wdiff-0.5-r3.ebuild b/app-text/wdiff/wdiff-0.5-r3.ebuild
new file mode 100644
index 000000000000..d6afdf05c938
--- /dev/null
+++ b/app-text/wdiff/wdiff-0.5-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/wdiff-0.5-r3.ebuild,v 1.1 2010/03/06 22:05:07 jlec Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="http://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-apps/diffutils
+ sys-apps/less"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-headers.patch
+ epatch "${FILESDIR}"/${P}-segfault-fix.diff
+ epatch "${FILESDIR}"/${P}-avoid-wraps.diff
+ epatch "${FILESDIR}"/${P}-ignore-case.patch
+ sed -i 's:-ltermcap:-lncurses:' configure
+}
+
+src_compile() {
+ # Cannot use econf here because the configure script that
+ # comes with wdiff is too old to understand the standard
+ # options.
+
+ tc-export CC
+ ./configure --prefix=/usr || die
+ echo '#define HAVE_TPUTS 1' >> config.h
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog NEWS README
+ doman wdiff.1
+}