summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-18 23:14:57 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-18 23:14:57 +0000
commited7375a5d77fe3d79aacf0b93de1a24ae5bb3264 (patch)
treee995bb5ab8bb149a31e029cdc95f559c1eaebd0f /app-text/wklej
parentFix compilation (#530978 by Leonid Kopylov, Chí-Thanh Christopher Nguyễn, ... (diff)
downloadgentoo-2-ed7375a5d77fe3d79aacf0b93de1a24ae5bb3264.tar.gz
gentoo-2-ed7375a5d77fe3d79aacf0b93de1a24ae5bb3264.tar.bz2
gentoo-2-ed7375a5d77fe3d79aacf0b93de1a24ae5bb3264.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-text/wklej')
-rw-r--r--app-text/wklej/ChangeLog10
-rw-r--r--app-text/wklej/wklej-0.2.1-r1.ebuild36
2 files changed, 43 insertions, 3 deletions
diff --git a/app-text/wklej/ChangeLog b/app-text/wklej/ChangeLog
index d6f6d6af89c3..5ddc33f0010b 100644
--- a/app-text/wklej/ChangeLog
+++ b/app-text/wklej/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/wklej
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wklej/ChangeLog,v 1.27 2011/03/30 21:29:02 aidecoe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wklej/ChangeLog,v 1.28 2015/01/18 23:14:57 mgorny Exp $
+
+*wklej-0.2.1-r1 (18 Jan 2015)
+
+ 18 Jan 2015; Michał Górny <mgorny@gentoo.org> +wklej-0.2.1-r1.ebuild:
+ Convert to python-single-r1.
30 Mar 2011; Amadeusz Żołnowski <aidecoe@gentoo.org> metadata.xml:
aidecoe has taken over the maintenance.
@@ -68,4 +73,3 @@
+wklej-0.1.5.ebuild:
Version bump (thanks to Antoni <awaria at chopin.edu.pl> and Paweł <pkilian
at wklej.org> for working on ebuild
-
diff --git a/app-text/wklej/wklej-0.2.1-r1.ebuild b/app-text/wklej/wklej-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..31045a88009f
--- /dev/null
+++ b/app-text/wklej/wklej-0.2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wklej/wklej-0.2.1-r1.ebuild,v 1.1 2015/01/18 23:14:57 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit python-single-r1
+
+DESCRIPTION="A wklej.org submitter"
+HOMEPAGE="http://wklej.org"
+SRC_URI="http://wklej.org/m/apps/wklej-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+vim"
+
+DEPEND=""
+RDEPEND="vim? ( app-editors/vim[python,$(python_gen_usedep 'python2*')] )"
+
+# the vim script works is python2-only...
+REQUIRED_USE="vim? ( ^^ ( $(python_gen_useflags 'python2*') ) )"
+
+S=${WORKDIR}
+
+src_install() {
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins ${PN}.vim
+ fi
+
+ python_doscript ${PN}
+ dodoc README wklejrc
+}