summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-05-16 00:29:08 +0000
committerSteve Dibb <beandog@gentoo.org>2010-05-16 00:29:08 +0000
commit68e0cf0360cb6f03f31a2221e2bfff0bc900413a (patch)
tree5879d3bbaa67b5d53dcf5b4445b2478c93dd3d70 /app-text/xiphos
parentVersion bump (diff)
downloadgentoo-2-68e0cf0360cb6f03f31a2221e2bfff0bc900413a.tar.gz
gentoo-2-68e0cf0360cb6f03f31a2221e2bfff0bc900413a.tar.bz2
gentoo-2-68e0cf0360cb6f03f31a2221e2bfff0bc900413a.zip
xulrunner bulid bug fix, bug 386853; thanks to Niko R. for patch
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xiphos')
-rw-r--r--app-text/xiphos/ChangeLog7
-rw-r--r--app-text/xiphos/xiphos-3.1.3-r1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/app-text/xiphos/ChangeLog b/app-text/xiphos/ChangeLog
index ba16d5d5bf76..49b3c22d1a37 100644
--- a/app-text/xiphos/ChangeLog
+++ b/app-text/xiphos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xiphos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/ChangeLog,v 1.7 2010/05/07 15:23:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/ChangeLog,v 1.8 2010/05/16 00:29:08 beandog Exp $
+
+*xiphos-3.1.3-r1 (16 May 2010)
+
+ 16 May 2010; Steve Dibb <beandog@gentoo.org> +xiphos-3.1.3-r1.ebuild:
+ xulrunner bulid bug fix, bug 386853; thanks to Niko R. for patch
07 May 2010; Samuli Suominen <ssuominen@gentoo.org> xiphos-3.1.2.ebuild:
amd64/x86 stable wrt #316145, thanks to Andreas Schürch for testing.
diff --git a/app-text/xiphos/xiphos-3.1.3-r1.ebuild b/app-text/xiphos/xiphos-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..68dcadb436ed
--- /dev/null
+++ b/app-text/xiphos/xiphos-3.1.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/xiphos-3.1.3-r1.ebuild,v 1.1 2010/05/16 00:29:08 beandog Exp $
+
+EAPI=2
+GCONF_DEBUG=no
+
+inherit gnome2 flag-o-matic
+
+DESCRIPTION="GTK+ based Bible study software, formerly gnomesword"
+HOMEPAGE="http://xiphos.org/"
+SRC_URI="mirror://sourceforge/gnomesword/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="xulrunner"
+
+RDEPEND="dev-libs/glib:2
+ >=x11-libs/gtk+-2.14:2
+ dev-libs/libxml2
+ >=gnome-base/libglade-2
+ >=gnome-extra/gtkhtml-3.23
+ >=app-text/sword-1.6
+ dev-libs/dbus-glib
+ gnome-extra/libgsf
+ xulrunner? ( >=net-libs/xulrunner-1.9.1.3:1.9 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ app-text/rarian
+ >=app-text/gnome-doc-utils-0.3.2
+ dev-libs/nspr"
+
+pkg_setup() {
+ G2CONF="--docdir=/usr/share/doc/${PF}
+ --disable-dependency-tracking"
+
+ if ! use xulrunner; then
+ G2CONF="${G2CONF} --without-gecko"
+ fi
+
+ append-cppflags -I/usr/include/nspr
+}
+
+src_install() {
+ gnome2_src_install
+ prepalldocs
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Xiphos requires modules to be of any use. You may install the"
+ elog "sword modules packages in app-dicts/, or download modules"
+ elog "individually from the sword website: http://crosswire.org/sword/"
+}