summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-07-24 19:47:29 +0000
committerSteve Dibb <beandog@gentoo.org>2009-07-24 19:47:29 +0000
commit88b8b0de01c37fd5c962a9218aa7003adfe4d4b8 (patch)
treedaba175e4b293ba2c82faccfb8d99460793c0f35 /app-text/xiphos
parentopenvas-plugins bump (diff)
downloadgentoo-2-88b8b0de01c37fd5c962a9218aa7003adfe4d4b8.tar.gz
gentoo-2-88b8b0de01c37fd5c962a9218aa7003adfe4d4b8.tar.bz2
gentoo-2-88b8b0de01c37fd5c962a9218aa7003adfe4d4b8.zip
Initial commit, bug 263309; Thanks to Greg <greg.hellings@gmail.com> for original ebuild
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xiphos')
-rw-r--r--app-text/xiphos/ChangeLog11
-rw-r--r--app-text/xiphos/metadata.xml8
-rw-r--r--app-text/xiphos/xiphos-3.1.ebuild61
3 files changed, 80 insertions, 0 deletions
diff --git a/app-text/xiphos/ChangeLog b/app-text/xiphos/ChangeLog
new file mode 100644
index 000000000000..b984f8051dfa
--- /dev/null
+++ b/app-text/xiphos/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/xiphos
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/ChangeLog,v 1.1 2009/07/24 19:47:29 beandog Exp $
+
+*xiphos-3.1 (24 Jul 2009)
+
+ 24 Jul 2009; Steve Dibb <beandog@gentoo.org> +xiphos-3.1.ebuild,
+ +metadata.xml:
+ Initial commit, bug 263309; Thanks to Greg <greg.hellings@gmail.com> for
+ original ebuild
+
diff --git a/app-text/xiphos/metadata.xml b/app-text/xiphos/metadata.xml
new file mode 100644
index 000000000000..4793618b140b
--- /dev/null
+++ b/app-text/xiphos/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>theology</herd>
+<maintainer>
+ <email>theology@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/xiphos/xiphos-3.1.ebuild b/app-text/xiphos/xiphos-3.1.ebuild
new file mode 100644
index 000000000000..db15657243d8
--- /dev/null
+++ b/app-text/xiphos/xiphos-3.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/xiphos-3.1.ebuild,v 1.1 2009/07/24 19:47:29 beandog Exp $
+
+EAPI="2"
+
+inherit libtool gnome2 eutils
+
+DESCRIPTION="GTK+ based Bible study software, formerly gnomesword"
+HOMEPAGE="http://xiphos.org"
+SRC_URI="mirror://sourceforge/gnomesword/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="firefox seamonkey spell xulrunner +gtkhtml"
+RDEPEND="
+ =app-text/sword-1.6.0
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libglade-2
+ app-text/gnome-doc-utils
+ dev-libs/libxml2
+ xulrunner? ( net-libs/xulrunner:1.8 )
+ !xulrunner? ( firefox? ( =www-client/mozilla-firefox-2* ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( =www-client/seamonkey-1* ) ) )
+ !xulrunner? ( !firefox? ( !seamonkey? ( gtkhtml? ( >=gnome-extra/gtkhtml-3.18 ) ) ) )
+ spell? (
+ app-text/gnome-spell
+ >=gnome-base/libbonoboui-2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.3.14"
+
+pkg_setup() {
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ elif use firefox; then
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ elif use seamonkey; then
+ G2CONF="${G2CONF} --with-gecko=seamonkey"
+ elif use gtkhtml; then
+ G2CONF="${G2CONF} --enable-gtkhtml"
+ else
+ eerror "Setup your USE flags to specify a backend to use:"
+ eerror "xulrunner, firefox, seamonkey or gtkhtml"
+ die "Fix USE flags"
+ fi
+ G2CONF="${G2CONF} $(use_enable spell pspell)"
+ DOCS="NEWS ChangeLog README TODO"
+
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Xiphos requires modules to be of any use. You may install the"
+ einfo "sword modules packages in app-dicts/, or download modules"
+ einfo "individually from the sword website: http://crosswire.org/sword/"
+}