summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-10-16 15:12:16 +0000
committerMike Gardiner <obz@gentoo.org>2003-10-16 15:12:16 +0000
commitfb1ba3d03ecee3914bc24359504cd0027edd5d5f (patch)
treed143bc369ee6010128f21c434a663ae4dbf69edf /app-text/xml2doc
parentFirst version in portage (diff)
downloadgentoo-2-fb1ba3d03ecee3914bc24359504cd0027edd5d5f.tar.gz
gentoo-2-fb1ba3d03ecee3914bc24359504cd0027edd5d5f.tar.bz2
gentoo-2-fb1ba3d03ecee3914bc24359504cd0027edd5d5f.zip
First version in portage
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/ChangeLog10
-rw-r--r--app-text/xml2doc/Manifest4
-rw-r--r--app-text/xml2doc/files/digest-xml2doc-200305101
-rw-r--r--app-text/xml2doc/metadata.xml5
-rw-r--r--app-text/xml2doc/xml2doc-20030510.ebuild43
5 files changed, 62 insertions, 1 deletions
diff --git a/app-text/xml2doc/ChangeLog b/app-text/xml2doc/ChangeLog
new file mode 100644
index 000000000000..ce46a7f4df7a
--- /dev/null
+++ b/app-text/xml2doc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/xml2doc
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/ChangeLog,v 1.1 2003/10/16 15:11:39 obz Exp $
+
+*xml2doc-20030510 (16 Oct 2003)
+
+ 16 Oct 2003; Mike Gardiner <obz@gentoo.org> xml2doc-20030510.ebuild:
+ First version in portage. Thanks to <brainlinux@softhome.net> for the initial
+ ideas on bug #20501.
+
diff --git a/app-text/xml2doc/Manifest b/app-text/xml2doc/Manifest
index 7b93f0046a6e..c27e9903f801 100644
--- a/app-text/xml2doc/Manifest
+++ b/app-text/xml2doc/Manifest
@@ -1,2 +1,4 @@
-MD5 8a19f7f511078995697eb4c4fc2764c2 xml2doc-20030510.ebuild 926
+MD5 f0f23edca8cc06cd25f75d83ea5b8385 ChangeLog 419
+MD5 bf041abda3dd101b346db4b42a472b7e xml2doc-20030510.ebuild 1026
+MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
MD5 7e303f487b570296c2d407c4bcf15736 files/digest-xml2doc-20030510 64
diff --git a/app-text/xml2doc/files/digest-xml2doc-20030510 b/app-text/xml2doc/files/digest-xml2doc-20030510
new file mode 100644
index 000000000000..de576d436ff6
--- /dev/null
+++ b/app-text/xml2doc/files/digest-xml2doc-20030510
@@ -0,0 +1 @@
+MD5 5cadf5d0c3ff8d9b150f332861c33f7e xml2doc-20030510.tgz 53307
diff --git a/app-text/xml2doc/metadata.xml b/app-text/xml2doc/metadata.xml
new file mode 100644
index 000000000000..06689a1a9114
--- /dev/null
+++ b/app-text/xml2doc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>text-markup</herd>
+</pkgmetadata>
diff --git a/app-text/xml2doc/xml2doc-20030510.ebuild b/app-text/xml2doc/xml2doc-20030510.ebuild
new file mode 100644
index 000000000000..5051e751d693
--- /dev/null
+++ b/app-text/xml2doc/xml2doc-20030510.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/xml2doc-20030510.ebuild,v 1.1 2003/10/16 15:11:39 obz Exp $
+
+DESCRIPTION="An XML processor tool that allows for converting documents written in simple XML to a variety of document formats (eg pdf,html,txt,manpage)"
+SRC_URI="mirror://sourceforge/${PN}/src/${P}.tgz"
+HOMEPAGE="http://xml2doc.sourceforge.net"
+LICENSE="GPL-2"
+
+IUSE="pdflib"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND=">=dev-libs/libxml2-2.5
+ pdflib? ( >=media-libs/pdflib-4 )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+
+ local myconf=""
+ use pdflib || myconf="${myconf} --disable-pdf"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ # xml2doc's make install is unfortunately broken
+ # binary
+ dobin ${S}/src/xml2doc
+ # documentation
+ dodoc BUGS README TODO
+ docinto examples
+ dodoc ${S}/examples/*.{xml,png}
+ # manpage
+ cd ${S}/doc
+ ${S}/src/xml2doc -oM manpage.xml xml2doc.1
+ doman xml2doc.1
+
+}