summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-05 18:24:20 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-05 18:24:20 +0000
commit0d7246d7016b95f3b457a9444ce99e9cdef0c52e (patch)
treeb7d5fc433db1185bc92f868ee7736c7376241169 /app-text
parentSome Clean up (diff)
downloadgentoo-2-0d7246d7016b95f3b457a9444ce99e9cdef0c52e.tar.gz
gentoo-2-0d7246d7016b95f3b457a9444ce99e9cdef0c52e.tar.bz2
gentoo-2-0d7246d7016b95f3b457a9444ce99e9cdef0c52e.zip
Version Bump, Some Clean up
(Portage version: 2.2.0_alpha12/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/hd2u/ChangeLog8
-rw-r--r--app-text/hd2u/files/hd2u-1.0.0-build.patch24
-rw-r--r--app-text/hd2u/files/hd2u-1.0.3-build.patch25
-rw-r--r--app-text/hd2u/hd2u-1.0.3.ebuild30
4 files changed, 75 insertions, 12 deletions
diff --git a/app-text/hd2u/ChangeLog b/app-text/hd2u/ChangeLog
index f1adcf2c60cf..d8fb52cc26a2 100644
--- a/app-text/hd2u/ChangeLog
+++ b/app-text/hd2u/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/hd2u
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hd2u/ChangeLog,v 1.37 2011/01/05 18:12:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hd2u/ChangeLog,v 1.38 2011/01/05 18:24:20 jlec Exp $
+
+*hd2u-1.0.3 (05 Jan 2011)
+
+ 05 Jan 2011; Justin Lecher <jlec@gentoo.org> files/hd2u-1.0.0-build.patch,
+ +hd2u-1.0.3.ebuild, +files/hd2u-1.0.3-build.patch:
+ Version Bump, Some Clean up
05 Jan 2011; Justin Lecher <jlec@gentoo.org> hd2u-1.0.0.ebuild:
Some Clean up
diff --git a/app-text/hd2u/files/hd2u-1.0.0-build.patch b/app-text/hd2u/files/hd2u-1.0.0-build.patch
index a88f210e71a7..66b32bbc17c7 100644
--- a/app-text/hd2u/files/hd2u-1.0.0-build.patch
+++ b/app-text/hd2u/files/hd2u-1.0.0-build.patch
@@ -1,19 +1,21 @@
---- Makefile.in
-+++ Makefile.in
-@@ -31,7 +31,7 @@
- README \
- TODO
- INSTALL = @INSTALL@
--LIBS= @LIBS@
-+LIBS= @LIBS@ @LDFLAGS@
-
+diff --git a/Makefile.in b/Makefile.in
+index 328016c..f8cc6aa 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -36,7 +36,7 @@ LIBS= @LIBS@
all: $(TARGET)
-@@ -59,9 +59,10 @@
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+ rebuild: cleanall $(TARGET)
+
+@@ -59,9 +59,10 @@ cleanall: clean
mrproper: cleanall
distclean: cleanall
-+BUILD_ROOT = $(DESTDIR)
++BUILD_ROOT=$(DESTDIR)
install:
$(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
diff --git a/app-text/hd2u/files/hd2u-1.0.3-build.patch b/app-text/hd2u/files/hd2u-1.0.3-build.patch
new file mode 100644
index 000000000000..de788e8aa774
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.3-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 2a67b3c..651323d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,7 +42,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+
+ all-optimized: $(TARGET)-optimized
+@@ -98,9 +98,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)
diff --git a/app-text/hd2u/hd2u-1.0.3.ebuild b/app-text/hd2u/hd2u-1.0.3.ebuild
new file mode 100644
index 000000000000..31d38ec4383d
--- /dev/null
+++ b/app-text/hd2u/hd2u-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hd2u/hd2u-1.0.3.ebuild,v 1.1 2011/01/05 18:24:20 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Dos2Unix like text file converter"
+HOMEPAGE="http://www.megaloman.com/~hany/software/hd2u/"
+SRC_URI="http://www.megaloman.com/~hany/_data/hd2u/${P}.tgz"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="
+ dev-libs/popt"
+RDEPEND="${DEPEND}
+ !app-text/dos2unix"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS CREDITS ChangeLog INSTALL NEWS README TODO || die
+}