summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-01 11:44:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-01 11:44:03 +0000
commit15d69cba8d7e8a67ef5fce156b84a7abeb2dc41d (patch)
treefc790a46659d6af2cc496d9bd45ee1cc7e7b6760 /app-text
parentalpha/arm/ia64/s390/sh/sparc/x86 stable wrt #271875 (diff)
downloadgentoo-2-15d69cba8d7e8a67ef5fce156b84a7abeb2dc41d.tar.gz
gentoo-2-15d69cba8d7e8a67ef5fce156b84a7abeb2dc41d.tar.bz2
gentoo-2-15d69cba8d7e8a67ef5fce156b84a7abeb2dc41d.zip
Bump to 1.6.0, closes #271965
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sword/ChangeLog7
-rw-r--r--app-text/sword/sword-1.6.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index c5c31607b286..6705f46a66be 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sword
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.51 2009/05/15 05:30:29 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.52 2009/06/01 11:44:03 patrick Exp $
+
+*sword-1.6.0 (01 Jun 2009)
+
+ 01 Jun 2009; Patrick Lauer <patrick@gentoo.org> +sword-1.6.0.ebuild:
+ Bump to 1.6.0, closes #271965
15 May 2009; Ryan Hill <dirtyepic@gentoo.org> sword-1.5.11.ebuild,
+files/sword-1.5.11-gcc44.patch:
diff --git a/app-text/sword/sword-1.6.0.ebuild b/app-text/sword/sword-1.6.0.ebuild
new file mode 100644
index 000000000000..e71c5a47d53a
--- /dev/null
+++ b/app-text/sword/sword-1.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.6.0.ebuild,v 1.1 2009/06/01 11:44:03 patrick Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Library for Bible reading software."
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="curl debug doc icu lucene"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu )
+ lucene? ( dev-cpp/clucene )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ strip-flags
+ econf --with-zlib \
+ --with-conf \
+ $(use_enable curl) \
+ $(use_enable debug) \
+ $(use_with icu) \
+ $(use_enable lucene) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS CODINGSTYLE ChangeLog INSTALL README
+ if use doc ;then
+ rm -rf examples/.cvsignore
+ rm -rf examples/cmdline/.cvsignore
+ rm -rf examples/cmdline/.deps
+ cp -R samples examples "${D}/usr/share/doc/${PF}/"
+ fi
+ # global configuration file
+ insinto /etc
+ doins "${FILESDIR}/sword.conf"
+}
+
+pkg_postinst() {
+ echo
+ elog "Check out http://www.crosswire.org/sword/modules/"
+ elog "to download modules that you would like to use with SWORD."
+ elog "Follow module installation instructions found on"
+ elog "the web or in /usr/share/doc/${PF}/INSTALL.gz."
+ echo
+}