summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 09:49:45 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 09:49:45 +0000
commit46b024a70e28fea4fa9724ea058c3aee74ea4504 (patch)
tree49638a3b8d5c5d86619664b23ff77620f76c7119 /app-text
parentStable on amd64 and x86. Fix license to be what webpage says. Remove older. (diff)
downloadgentoo-2-46b024a70e28fea4fa9724ea058c3aee74ea4504.tar.gz
gentoo-2-46b024a70e28fea4fa9724ea058c3aee74ea4504.tar.bz2
gentoo-2-46b024a70e28fea4fa9724ea058c3aee74ea4504.zip
Bump pandoc to 1.9.3
(Portage version: 2.1.10.64/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pandoc/ChangeLog8
-rw-r--r--app-text/pandoc/files/pandoc-1.9.3-ghc-7.5.patch75
-rw-r--r--app-text/pandoc/pandoc-1.9.3.ebuild82
3 files changed, 164 insertions, 1 deletions
diff --git a/app-text/pandoc/ChangeLog b/app-text/pandoc/ChangeLog
index 59fab68e1c17..1203d411d25b 100644
--- a/app-text/pandoc/ChangeLog
+++ b/app-text/pandoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pandoc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.5 2012/04/07 05:24:37 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.6 2012/06/02 09:49:45 gienah Exp $
+
+*pandoc-1.9.3 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org>
+ +files/pandoc-1.9.3-ghc-7.5.patch, +pandoc-1.9.3.ebuild:
+ Bump pandoc to 1.9.3
*pandoc-1.9.2 (07 Apr 2012)
diff --git a/app-text/pandoc/files/pandoc-1.9.3-ghc-7.5.patch b/app-text/pandoc/files/pandoc-1.9.3-ghc-7.5.patch
new file mode 100644
index 000000000000..4a8b013b57a4
--- /dev/null
+++ b/app-text/pandoc/files/pandoc-1.9.3-ghc-7.5.patch
@@ -0,0 +1,75 @@
+--- pandoc-1.9.3-orig/pandoc.cabal 2012-05-13 13:04:40.000000000 +1000
++++ pandoc-1.9.3/pandoc.cabal 2012-05-19 16:39:31.005923639 +1000
+@@ -193,7 +193,7 @@
+ -- Note: the following is duplicated in all stanzas.
+ -- It needs to be duplicated because of the library & executable flags.
+ -- BEGIN DUPLICATED SECTION
+- Build-Depends: containers >= 0.1 && < 0.5,
++ Build-Depends: containers >= 0.1 && < 0.6,
+ parsec >= 3.1 && < 3.2,
+ mtl >= 1.1 && < 2.2,
+ network >= 2 && < 2.4,
+@@ -298,7 +298,7 @@
+ -- Note: the following is duplicated in all stanzas.
+ -- It needs to be duplicated because of the library & executable flags.
+ -- BEGIN DUPLICATED SECTION
+- Build-Depends: containers >= 0.1 && < 0.5,
++ Build-Depends: containers >= 0.1 && < 0.6,
+ parsec >= 3.1 && < 3.2,
+ mtl >= 1.1 && < 2.2,
+ network >= 2 && < 2.4,
+@@ -362,7 +362,7 @@
+ -- Note: the following is duplicated in all stanzas.
+ -- It needs to be duplicated because of the library & executable flags.
+ -- BEGIN DUPLICATED SECTION
+- Build-Depends: containers >= 0.1 && < 0.5,
++ Build-Depends: containers >= 0.1 && < 0.6,
+ parsec >= 3.1 && < 3.2,
+ mtl >= 1.1 && < 2.2,
+ network >= 2 && < 2.4,
+--- pandoc-1.9.3-orig/Setup.hs 2012-05-13 13:04:40.000000000 +1000
++++ pandoc-1.9.3/Setup.hs 2012-05-19 17:03:57.948263601 +1000
+@@ -1,3 +1,5 @@
++{-# LANGUAGE CPP #-}
++
+ import Distribution.Simple
+ import Distribution.Simple.Setup
+ (copyDest, copyVerbosity, fromFlag, installVerbosity, BuildFlags(..))
+@@ -20,6 +22,10 @@
+ import Data.Maybe ( catMaybes )
+ import Data.List ( (\\) )
+
++#if (__GLASGOW_HASKELL__>=705)
++import Data.Time.Clock.POSIX ( utcTimeToPOSIXSeconds )
++#endif
++
+ main :: IO ()
+ main = do
+ defaultMainWithHooks $ simpleUserHooks {
+@@ -89,14 +95,24 @@
+ installOrdinaryFiles verbosity (mandir (absoluteInstallDirs pkg lbi copy))
+ (zip (repeat manDir) manpages)
+
++getModificationTime' :: FilePath -> IO ClockTime
++getModificationTime' file =
++#if (__GLASGOW_HASKELL__>=705)
++ do utcTime <- getModificationTime file
++ let s = (toEnum . fromEnum . utcTimeToPOSIXSeconds) utcTime
++ return (TOD s 0)
++#else
++ getModificationTime file
++#endif
++
+ -- | Returns a list of 'dependencies' that have been modified after 'file'.
+ modifiedDependencies :: FilePath -> [FilePath] -> IO [FilePath]
+ modifiedDependencies file dependencies = do
+- fileModTime <- catch (getModificationTime file) $
++ fileModTime <- catch (getModificationTime' file) $
+ \e -> if isDoesNotExistError e
+ then return (TOD 0 0) -- the minimum ClockTime
+ else ioError e
+- depModTimes <- mapM getModificationTime dependencies
++ depModTimes <- mapM getModificationTime' dependencies
+ let modified = zipWith (\dep time -> if time > fileModTime then Just dep else Nothing) dependencies depModTimes
+ return $ catMaybes modified
+
diff --git a/app-text/pandoc/pandoc-1.9.3.ebuild b/app-text/pandoc/pandoc-1.9.3.ebuild
new file mode 100644
index 000000000000..d7db206265f7
--- /dev/null
+++ b/app-text/pandoc/pandoc-1.9.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/pandoc-1.9.3.ebuild,v 1.1 2012/06/02 09:49:45 gienah Exp $
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="Conversion between markup formats"
+HOMEPAGE="http://johnmacfarlane.net/pandoc"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="=dev-haskell/base64-bytestring-0.1*[profile?]
+ =dev-haskell/blaze-html-0.5*[profile?]
+ >=dev-haskell/blaze-markup-0.5.1[profile?]
+ <dev-haskell/blaze-markup-0.6[profile?]
+ >=dev-haskell/citeproc-hs-0.3.4[profile?]
+ <dev-haskell/citeproc-hs-0.4[profile?]
+ >=dev-haskell/highlighting-kate-0.5.0.2[profile?]
+ <dev-haskell/highlighting-kate-0.6[profile?]
+ >=dev-haskell/http-4000.0.5[profile?]
+ <dev-haskell/http-4000.3[profile?]
+ >=dev-haskell/json-0.4[profile?]
+ <dev-haskell/json-0.6[profile?]
+ >=dev-haskell/mtl-1.1[profile?]
+ <dev-haskell/mtl-2.2[profile?]
+ >=dev-haskell/network-2[profile?]
+ <dev-haskell/network-2.4[profile?]
+ >=dev-haskell/pandoc-types-1.9.0.2[profile?]
+ <dev-haskell/pandoc-types-1.10[profile?]
+ =dev-haskell/parsec-3.1*[profile?]
+ >=dev-haskell/random-1[profile?]
+ <dev-haskell/random-1.1[profile?]
+ >=dev-haskell/syb-0.1[profile?]
+ <dev-haskell/syb-0.4[profile?]
+ >=dev-haskell/tagsoup-0.12.5[profile?]
+ <dev-haskell/tagsoup-0.13[profile?]
+ =dev-haskell/temporary-1.1*[profile?]
+ >=dev-haskell/texmath-0.6.0.2[profile?]
+ <dev-haskell/texmath-0.7[profile?]
+ >=dev-haskell/time-1.2[profile?]
+ <dev-haskell/time-1.5[profile?]
+ =dev-haskell/utf8-string-0.3*[profile?]
+ >=dev-haskell/xml-1.3.12[profile?]
+ <dev-haskell/xml-1.4[profile?]
+ >=dev-haskell/zip-archive-0.1.1.7[profile?]
+ <dev-haskell/zip-archive-0.2[profile?]
+ =dev-haskell/zlib-0.5*[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/ansi-terminal[profile?]
+ dev-haskell/diff[profile?]
+ dev-haskell/hunit[profile?]
+ dev-haskell/quickcheck:2[profile?]
+ dev-haskell/test-framework-hunit[profile?]
+ dev-haskell/test-framework-quickcheck2[profile?]
+ dev-haskell/test-framework[profile?]
+ )
+ "
+
+PATCHES=("${FILESDIR}/${PN}-1.9.3-ghc-7.5.patch")
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag test tests)
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/man/man1/${PN}.1"
+
+ # COPYING is installed by the Cabal eclass
+ dodoc README COPYRIGHT changelog
+}