summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2002-11-11 13:51:02 +0000
committerJon Nall <nall@gentoo.org>2002-11-11 13:51:02 +0000
commit7c3e313728001bb60f3627c65df6ed949e20c7b2 (patch)
tree7ac08e29af9f906bf9fc5d90408d64de3b234e0b /app-text
parentUpdated trusted users and added a sed for MySQL socket. (diff)
downloadgentoo-2-7c3e313728001bb60f3627c65df6ed949e20c7b2.tar.gz
gentoo-2-7c3e313728001bb60f3627c65df6ed949e20c7b2.tar.bz2
gentoo-2-7c3e313728001bb60f3627c65df6ed949e20c7b2.zip
fix for bug #9996
Diffstat (limited to 'app-text')
-rw-r--r--app-text/aspell/ChangeLog17
-rw-r--r--app-text/aspell/aspell-0.50.2-r1.ebuild76
-rw-r--r--app-text/aspell/files/digest-aspell-0.50.2-r11
3 files changed, 93 insertions, 1 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index 1a7c40fe483d..d60fc71b5cb7 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for app-text/aspell
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.16 2002/10/26 04:02:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.17 2002/11/11 13:51:02 nall Exp $
+
+*aspell-0.50.2-r1 (11 Nov 2002)
+
+ 11 Nov 2002; Jon Nall <nall@gentoo.org> aspell-0.50.2-r1.ebuild
+ files/digest-aspell-0.50.2-r1 :
+
+ This fixes a problem where applications are linked against both
+ libaspell.so AND libaspell-common.so. when aspell is upgraded,
+ the libaspell-common.so version is bumped and apps break. using
+ --remove-internal-dep=aspell-common with cause apps to link
+ only against libaspell.so, which should allow them to work across
+ multiple aspell versions. This fixes bug #9996.
+ NOTE: all apps that compile against aspell will need to be
+ recompiled (abiword, sylpheed-claws, gnome-spell, etc)
+
*aspell-0.50.2 (05 Oct 2002)
diff --git a/app-text/aspell/aspell-0.50.2-r1.ebuild b/app-text/aspell/aspell-0.50.2-r1.ebuild
new file mode 100644
index 000000000000..9066c53f862e
--- /dev/null
+++ b/app-text/aspell/aspell-0.50.2-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.2-r1.ebuild,v 1.1 2002/11/11 13:51:02 nall Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A spell checker replacement for ispell"
+SRC_URI="ftp://ftp.gnu.org/gnu/aspell/${P}.tar.gz"
+HOMEPAGE="http://aspell.net/"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+#
+# These flags a reset here because too much optimisation can cause aspell's
+# compilation process to break. Moreover, these must be set before ./configure
+# otherwise it breaks again. A very fragile build process, really.
+#
+#CXXFLAGS="-O2"
+#CFLAGS=${CXXFLAGS}
+
+# humm .. why are they comented? cselkirk
+
+pkg_setup() {
+ if [ ${ARCH} = "ppc" ] ; then
+ CXXFLAGS="-O2 -fsigned-char"
+ CFLAGS=${CXXFLAGS}
+ fi
+}
+
+src_compile() {
+ elibtoolize --reverse-deps --remove-internal-dep=aspell-common
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ cd ${D}/usr/share/doc/${P}
+ dohtml -r man-html
+ rm -rf man-html
+ docinto text
+ dodoc man-text
+ rm -rf man-text
+ cd ${S}
+
+ dodoc README* TODO
+
+ cd examples
+ make clean || die
+ cd ${S}
+
+ docinto examples
+ dodoc examples/*
+
+}
+
+pkg_postinst() {
+
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-i18n category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+}
diff --git a/app-text/aspell/files/digest-aspell-0.50.2-r1 b/app-text/aspell/files/digest-aspell-0.50.2-r1
new file mode 100644
index 000000000000..1c982734c9f8
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.50.2-r1
@@ -0,0 +1 @@
+MD5 d6c3d50c355bc2e6b2f253a1f7209b92 aspell-0.50.2.tar.gz 922061