summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-08-20 15:55:14 +0000
committerUlrich Müller <ulm@gentoo.org>2007-08-20 15:55:14 +0000
commit8eef91105a55c6ffd316eb02842ec34ee8cdff29 (patch)
treefff31be5f68a596a4654bca4e406dc441c2007ae /app-text
parentVersion bump. (diff)
downloadgentoo-2-8eef91105a55c6ffd316eb02842ec34ee8cdff29.tar.gz
gentoo-2-8eef91105a55c6ffd316eb02842ec34ee8cdff29.tar.bz2
gentoo-2-8eef91105a55c6ffd316eb02842ec34ee8cdff29.zip
Update Emacs support, bug #184261.
(Portage version: 2.1.3.6)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/txt2tags/ChangeLog8
-rw-r--r--app-text/txt2tags/files/51txt2tags-gentoo.el6
-rw-r--r--app-text/txt2tags/files/digest-txt2tags-2.3-r13
-rw-r--r--app-text/txt2tags/txt2tags-2.3-r1.ebuild75
4 files changed, 91 insertions, 1 deletions
diff --git a/app-text/txt2tags/ChangeLog b/app-text/txt2tags/ChangeLog
index 6a7bbef44aa9..e853beeba4cd 100644
--- a/app-text/txt2tags/ChangeLog
+++ b/app-text/txt2tags/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/txt2tags
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/txt2tags/ChangeLog,v 1.24 2007/03/12 23:35:26 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/txt2tags/ChangeLog,v 1.25 2007/08/20 15:55:13 ulm Exp $
+
+*txt2tags-2.3-r1 (20 Aug 2007)
+
+ 20 Aug 2007; Ulrich Mueller <ulm@gentoo.org> +files/51txt2tags-gentoo.el,
+ +txt2tags-2.3-r1.ebuild:
+ Update Emacs support, bug #184261.
12 Mar 2007; Leonardo Boshell <leonardop@gentoo.org> metadata.xml,
-txt2tags-1.7.ebuild, -txt2tags-2.2.ebuild:
diff --git a/app-text/txt2tags/files/51txt2tags-gentoo.el b/app-text/txt2tags/files/51txt2tags-gentoo.el
new file mode 100644
index 000000000000..0b98bd66b8b2
--- /dev/null
+++ b/app-text/txt2tags/files/51txt2tags-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; txt2tags site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 't2t-mode "txt2tags-mode" "Major mode for editing Txt2Tags files" t)
+(add-to-list 'auto-mode-alist '("\\.t2t\\'" . t2t-mode))
diff --git a/app-text/txt2tags/files/digest-txt2tags-2.3-r1 b/app-text/txt2tags/files/digest-txt2tags-2.3-r1
new file mode 100644
index 000000000000..3efa052ecd62
--- /dev/null
+++ b/app-text/txt2tags/files/digest-txt2tags-2.3-r1
@@ -0,0 +1,3 @@
+MD5 0514bb01161183808dc8be105c032677 txt2tags-2.3.tgz 880164
+RMD160 320abbee12eb8be5e35d02068c0ff8db17734d6c txt2tags-2.3.tgz 880164
+SHA256 27759aceb384ab333db9ead28274dbd6cf0101c661564e155aa4252f9ec6bda5 txt2tags-2.3.tgz 880164
diff --git a/app-text/txt2tags/txt2tags-2.3-r1.ebuild b/app-text/txt2tags/txt2tags-2.3-r1.ebuild
new file mode 100644
index 000000000000..684f51c36e25
--- /dev/null
+++ b/app-text/txt2tags/txt2tags-2.3-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/txt2tags/txt2tags-2.3-r1.ebuild,v 1.1 2007/08/20 15:55:13 ulm Exp $
+
+inherit elisp-common
+
+DESCRIPTION="A tool for generating marked up documents (HTML, SGML, ...) from a plain text file with markup"
+HOMEPAGE="http://txt2tags.sourceforge.net/"
+SRC_URI="mirror://sourceforge/txt2tags/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="emacs tk"
+
+DEPEND="virtual/python
+ tk? ( dev-lang/tk )
+ emacs? ( virtual/emacs )"
+
+SITEFILE="51${PN}-gentoo.el"
+
+pkg_setup() {
+ # need to test if the tk support in python is working
+ if use tk; then
+ if ! python -c "import _tkinter" 2>&1 > /dev/null ; then
+ echo
+ eerror "You have requested tk, but your build of Python"
+ eerror "doesnt support import _tkinter. You may need to"
+ eerror "remerge dev-lang/python, or build ${P}"
+ eerror "with USE=\"-tk\""
+ die
+ fi
+ fi
+}
+
+src_compile() {
+ if use emacs; then
+ elisp-compile extras/txt2tags-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ dobin txt2tags
+
+ dodoc README* TEAM TODO ChangeLog* doc/txt2tagsrc
+ dohtml -r doc/*
+ insinto /usr/share/doc/${PF}
+ doins doc/userguide.pdf
+ # samples go into "samples" doc directory
+ docinto samples
+ dodoc samples/sample.*
+ docinto samples/css
+ dodoc samples/css/*
+ docinto samples/img
+ dodoc samples/img/*
+ # extras go into "extras" doc directory
+ docinto extras
+ dodoc extras/*
+
+ newman doc/manpage.man txt2tags.1
+
+ # emacs support
+ if use emacs; then
+ elisp-install ${PN} extras/txt2tags-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}