summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-02-11 00:30:51 +0000
committerBen de Groot <yngwin@gentoo.org>2010-02-11 00:30:51 +0000
commit971495ad43b179b901ea4dd3e828dc9223be092b (patch)
tree1f50c1259a12c7a7be158cdbff159ddbb3be96be /app-text
parentVersion bump (diff)
downloadgentoo-2-971495ad43b179b901ea4dd3e828dc9223be092b.tar.gz
gentoo-2-971495ad43b179b901ea4dd3e828dc9223be092b.tar.bz2
gentoo-2-971495ad43b179b901ea4dd3e828dc9223be092b.zip
Add small patch for typo in configuration (bug 304407). Add ewarn to prompt users to recompile reverse dependencies (bug 304035).
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/ChangeLog7
-rw-r--r--app-text/poppler/files/poppler-0.12.3-config.patch107
-rw-r--r--app-text/poppler/poppler-0.12.3-r3.ebuild9
3 files changed, 121 insertions, 2 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index e8a01fdbfbcd..02cef0f6f1b0 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.218 2010/02/09 23:41:01 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.219 2010/02/11 00:30:49 yngwin Exp $
+
+ 11 Feb 2010; Ben de Groot <yngwin@gentoo.org> poppler-0.12.3-r3.ebuild,
+ +files/poppler-0.12.3-config.patch:
+ Add small patch for typo in configuration (bug 304407). Add ewarn to
+ prompt users to recompile reverse dependencies (bug 304035).
09 Feb 2010; Ben de Groot <yngwin@gentoo.org> -poppler-0.8.7.ebuild,
poppler-0.12.3-r3.ebuild, poppler-0.12.3-r4.ebuild:
diff --git a/app-text/poppler/files/poppler-0.12.3-config.patch b/app-text/poppler/files/poppler-0.12.3-config.patch
new file mode 100644
index 000000000000..1fc4f8a0f889
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.12.3-config.patch
@@ -0,0 +1,107 @@
+diff -urN poppler-0.12.3.sav/CMakeLists.txt poppler-0.12.3/CMakeLists.txt
+--- poppler-0.12.3.sav/CMakeLists.txt 2009-12-24 11:50:12.000000000 +0100
++++ poppler-0.12.3/CMakeLists.txt 2010-02-10 20:29:54.000000000 +0100
+@@ -33,7 +33,7 @@
+ set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)")
+
+ # Enable these unconditionally.
+-set(MULTITHREAD ON)
++set(MULTITHREADED ON)
+ set(OPI_SUPPORT ON)
+ set(TEXTOUT_WORD_LIST ON)
+
+diff -urN poppler-0.12.3.sav/poppler/poppler-config.h poppler-0.12.3/poppler/poppler-config.h
+--- poppler-0.12.3.sav/poppler/poppler-config.h 2009-12-24 11:51:39.000000000 +0100
++++ poppler-0.12.3/poppler/poppler-config.h 1970-01-01 01:00:00.000000000 +0100
+@@ -1,91 +0,0 @@
+-/* poppler/poppler-config.h. Generated from poppler-config.h.in by configure. */
+-//================================================= -*- mode: c++ -*- ====
+-//
+-// poppler-config.h
+-//
+-// Copyright 1996-2004 Glyph & Cog, LLC
+-//
+-//========================================================================
+-
+-#ifndef POPPLER_CONFIG_H
+-#define POPPLER_CONFIG_H
+-
+-// We duplicate some of the config.h #define's here since they are
+-// used in some of the header files we install. The #ifndef/#endif
+-// around #undef look odd, but it's to silence warnings about
+-// redefining those symbols.
+-
+-/* Enable multithreading support. */
+-#ifndef MULTITHREADED
+-#define MULTITHREADED 1
+-#endif
+-
+-/* Enable exceptions. */
+-#ifndef USE_EXCEPTIONS
+-/* #undef USE_EXCEPTIONS */
+-#endif
+-
+-/* Use fixedpoint. */
+-#ifndef USE_FIXEDPOINT
+-/* #undef USE_FIXEDPOINT */
+-#endif
+-
+-/* Include support for OPI comments. */
+-#ifndef OPI_SUPPORT
+-#define OPI_SUPPORT 1
+-#endif
+-
+-/* Enable word list support. */
+-#ifndef TEXTOUT_WORD_LIST
+-#define TEXTOUT_WORD_LIST 1
+-#endif
+-
+-// Also, there's a couple of preprocessor symbols in the header files
+-// that are used but never defined: DISABLE_OUTLINE, DEBUG_MEM and
+-
+-//------------------------------------------------------------------------
+-// version
+-//------------------------------------------------------------------------
+-
+-// copyright notice
+-#define popplerCopyright "Copyright 2005-2009 The Poppler Developers - http://poppler.freedesktop.org"
+-#define xpdfCopyright "Copyright 1996-2004 Glyph & Cog, LLC"
+-
+-//------------------------------------------------------------------------
+-// popen
+-//------------------------------------------------------------------------
+-
+-#if defined(_MSC_VER) || defined(__BORLANDC__)
+-#define popen _popen
+-#define pclose _pclose
+-#endif
+-
+-#if defined(VMS) || defined(VMCMS) || defined(DOS) || defined(OS2) || defined(__EMX__) || defined(_WIN32) || defined(__DJGPP__) || defined(MACOS)
+-#define POPEN_READ_MODE "rb"
+-#else
+-#define POPEN_READ_MODE "r"
+-#endif
+-
+-//------------------------------------------------------------------------
+-// Win32 stuff
+-//------------------------------------------------------------------------
+-
+-#if defined(_WIN32) && !defined(_MSC_VER)
+-#include <windef.h>
+-#else
+-#define CDECL
+-#endif
+-
+-//------------------------------------------------------------------------
+-// Compiler
+-//------------------------------------------------------------------------
+-
+-#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ > 4)
+-#define GCC_PRINTF_FORMAT(fmt_index, va_index) \
+- __attribute__((__format__(__printf__, fmt_index, va_index)))
+-#else
+-#define GCC_PRINTF_FORMAT(fmt_index, va_index)
+-#endif
+-
+-
+-#endif /* POPPLER_CONFIG_H */
diff --git a/app-text/poppler/poppler-0.12.3-r3.ebuild b/app-text/poppler/poppler-0.12.3-r3.ebuild
index 77ee4eadd738..1092bf9d2e86 100644
--- a/app-text/poppler/poppler-0.12.3-r3.ebuild
+++ b/app-text/poppler/poppler-0.12.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.3-r3.ebuild,v 1.11 2010/02/09 23:41:01 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.3-r3.ebuild,v 1.12 2010/02/11 00:30:49 yngwin Exp $
EAPI="2"
@@ -42,6 +42,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-fix-headers-installation.patch
epatch "${FILESDIR}"/${P}-gdk.patch
epatch "${FILESDIR}"/${P}-darwin-gtk-link.patch
+ epatch "${FILESDIR}"/${P}-config.patch #304407
}
src_configure() {
@@ -76,3 +77,9 @@ src_install() {
doins -r "${S}"/glib/reference/html/* || die 'failed to install API documentation'
fi
}
+
+pkg_postinst() {
+ ewarn 'After upgrading app-text/poppler you may need to reinstall packages'
+ ewarn 'depending on it. If you have gentoolkit installed, you can find those'
+ ewarn 'with `equery d poppler`.'
+}