summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-18 14:32:41 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-18 14:32:41 +0000
commitaef89a0e0be5543f64c721d2342c7a31d4a72346 (patch)
treed2e92abbf3468008f5ce4db19d7136be7440fa51 /app-text
parentRe-added temporarily PROVIDE=virtual/lapack (diff)
downloadgentoo-2-aef89a0e0be5543f64c721d2342c7a31d4a72346.tar.gz
gentoo-2-aef89a0e0be5543f64c721d2342c7a31d4a72346.tar.bz2
gentoo-2-aef89a0e0be5543f64c721d2342c7a31d4a72346.zip
Only GNU getopt (userland call) supports long options
(Portage version: 2.1.3.14)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rarian/ChangeLog6
-rw-r--r--app-text/rarian/files/rarian-0.6.0-posix-getopt.patch59
-rw-r--r--app-text/rarian/rarian-0.6.0.ebuild9
3 files changed, 71 insertions, 3 deletions
diff --git a/app-text/rarian/ChangeLog b/app-text/rarian/ChangeLog
index 303b428571c8..975367e63361 100644
--- a/app-text/rarian/ChangeLog
+++ b/app-text/rarian/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/rarian
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/ChangeLog,v 1.3 2007/10/18 13:47:21 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/ChangeLog,v 1.4 2007/10/18 14:32:41 uberlord Exp $
+
+ 18 Oct 2007; Roy Marples <uberlord@gentoo.org>
+ +files/rarian-0.6.0-posix-getopt.patch, rarian-0.6.0.ebuild:
+ Only GNU getopt (userland call) supports long options
18 Oct 2007; Roy Marples <uberlord@gentoo.org> rarian-0.6.0.ebuild:
Keyworded ~x86-fbsd
diff --git a/app-text/rarian/files/rarian-0.6.0-posix-getopt.patch b/app-text/rarian/files/rarian-0.6.0-posix-getopt.patch
new file mode 100644
index 000000000000..edb55f23fcef
--- /dev/null
+++ b/app-text/rarian/files/rarian-0.6.0-posix-getopt.patch
@@ -0,0 +1,59 @@
+diff -ur a/util/rarian-sk-update.in b/util/rarian-sk-update.in
+--- a/util/rarian-sk-update.in 2007-09-01 18:22:35 +0100
++++ b/util/rarian-sk-update.in 2007-10-18 15:27:42 +0100
+@@ -258,10 +258,7 @@
+ # They are inherited from scrollkeeper :(
+
+ # We use TEMP as set -- seems to nuke the return value of getopt
+-TEMP=`getopt -u -n$(basename $0) -o "o:r:p:vqnhV" \
+- --longoptions="clean-index,omf-dir:,resulting-dir:,help,version" -- "$@"` \
+- || print_usage
+-
++TEMP=`getopt "o:r:p:cvqnhV" "$@"`
+ if [ $? != 0 ] ; then
+ print_usage
+ exit 0
+@@ -271,12 +268,12 @@
+
+ while true; do
+ case "$1" in
+- -o | --omf-dir )
++ -o )
+ convert_dir=$2
+ update_output_dir=1
+ shift 2
+ ;;
+- -r | --result-dir )
++ -r )
+ output_dir=$2
+ overload_update=1
+ shift 2
+@@ -288,7 +285,7 @@
+ -q )
+ shift
+ ;;
+- --clean-index )
++ -c )
+ clean_index=1
+ shift
+ ;;
+@@ -299,9 +296,9 @@
+ # Scrollkeeper compat. Actually do nothing
+ shift
+ ;;
+- -p )
+- statedir=$2
+- shift 2
++ -p )
++ statedir=$2
++ shift 2
+ ;;
+ -V | --version )
+ print_version
+@@ -416,4 +413,4 @@
+ fi
+ rm -rf $tmpdir
+
+-fi # ENABLE_OMF_READ
+\ No newline at end of file
++fi # ENABLE_OMF_READ
diff --git a/app-text/rarian/rarian-0.6.0.ebuild b/app-text/rarian/rarian-0.6.0.ebuild
index 4cbdbc6a6b14..0094cc38fcce 100644
--- a/app-text/rarian/rarian-0.6.0.ebuild
+++ b/app-text/rarian/rarian-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/rarian-0.6.0.ebuild,v 1.3 2007/10/18 13:47:21 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/rarian-0.6.0.ebuild,v 1.4 2007/10/18 14:32:41 uberlord Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="A documentation metadata library"
HOMEPAGE="www.freedesktop.org"
@@ -25,5 +25,10 @@ src_unpack() {
# calling gnome2_omf_fix
unpack ${A}
cd "${S}"
+
+ # Only GNU getopt supports long options
+ # Scrollkeeper didn't support them, so we'll punt them for now
+ epatch "${FILESDIR}/${P}"-posix-getopt.patch
+
elibtoolize ${ELTCONF}
}