summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-03 09:32:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-03 09:32:31 +0000
commitd0bd3f64a005673cd92087423276d475a625f04b (patch)
tree7ebef4ef7cf1532faf7f1bfb4482574ffb13899f /app-text
parentadd ~arm, bug #285952 (diff)
downloadgentoo-2-d0bd3f64a005673cd92087423276d475a625f04b.tar.gz
gentoo-2-d0bd3f64a005673cd92087423276d475a625f04b.tar.bz2
gentoo-2-d0bd3f64a005673cd92087423276d475a625f04b.zip
version bump, drop cjk patches they cause more harm than good
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xdvik/ChangeLog10
-rw-r--r--app-text/xdvik/files/xdvik-22.84.16-open-mode.patch12
-rw-r--r--app-text/xdvik/xdvik-22.84.16.ebuild92
3 files changed, 112 insertions, 2 deletions
diff --git a/app-text/xdvik/ChangeLog b/app-text/xdvik/ChangeLog
index d761dcb370f6..c8736d15a251 100644
--- a/app-text/xdvik/ChangeLog
+++ b/app-text/xdvik/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/xdvik
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.63 2009/02/08 11:07:00 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.64 2009/10/03 09:32:30 aballier Exp $
+
+*xdvik-22.84.16 (03 Oct 2009)
+
+ 03 Oct 2009; Alexis Ballier <aballier@gentoo.org> +xdvik-22.84.16.ebuild,
+ +files/xdvik-22.84.16-open-mode.patch:
+ version bump, drop cjk patches they cause more harm than good
*xdvik-22.84.14-r1 (08 Feb 2009)
diff --git a/app-text/xdvik/files/xdvik-22.84.16-open-mode.patch b/app-text/xdvik/files/xdvik-22.84.16-open-mode.patch
new file mode 100644
index 000000000000..76ee267dc1a3
--- /dev/null
+++ b/app-text/xdvik/files/xdvik-22.84.16-open-mode.patch
@@ -0,0 +1,12 @@
+diff -pruN xdvik-22.84.14.orig/texk/xdvik/util.c xdvik-22.84.14/texk/xdvik/util.c
+--- xdvik-22.84.14.orig/texk/xdvik/util.c 2009-09-02 21:30:39.812675433 +0200
++++ xdvik-22.84.14/texk/xdvik/util.c 2008-05-03 21:45:10.000000000 +0200
+@@ -273,7 +273,7 @@ try_open_mode(const char *fname, int fla
+ int fd = open(fname, flags, mode);
+ if (fd < 0 && (errno == EMFILE || errno == ENFILE)) {
+ close_a_file();
+- fd = open(fname, flags);
++ fd = open(fname, flags, mode);
+ }
+ return fd;
+ }
diff --git a/app-text/xdvik/xdvik-22.84.16.ebuild b/app-text/xdvik/xdvik-22.84.16.ebuild
new file mode 100644
index 000000000000..13baef8fa38c
--- /dev/null
+++ b/app-text/xdvik/xdvik-22.84.16.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/xdvik-22.84.16.ebuild,v 1.1 2009/10/03 09:32:30 aballier Exp $
+
+inherit eutils flag-o-matic elisp-common toolchain-funcs
+
+DESCRIPTION="DVI previewer for X Window System"
+HOMEPAGE="http://xdvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xdvi/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="motif neXt Xaw3d emacs"
+
+RDEPEND=">=media-libs/t1lib-5.0.2
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXpm
+ motif? ( x11-libs/openmotif )
+ !motif? ( neXt? ( x11-libs/neXtaw )
+ !neXt? ( Xaw3d? ( x11-libs/Xaw3d ) ) )
+ virtual/latex-base
+ !<app-text/texlive-2007"
+DEPEND="${RDEPEND}"
+TEXMF_PATH=/usr/share/texmf
+S=${WORKDIR}/${P}/texk/xdvik
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-open-mode.patch"
+}
+
+src_compile() {
+ cd "${WORKDIR}/${P}"
+
+ tc-export CC AR RANLIB
+
+ local toolkit
+
+ if use motif ; then
+ toolkit="motif"
+ elif use neXt ; then
+ toolkit="neXtaw"
+ elif use Xaw3d ; then
+ toolkit="xaw3d"
+ else
+ toolkit="xaw"
+ fi
+
+ econf --disable-multiplatform \
+ --enable-t1lib \
+ --enable-gf \
+ --with-system-t1lib \
+ --with-system-kpathsea \
+ --with-kpathsea-include=/usr/include/kpathsea \
+ --with-xdvi-x-toolkit="${toolkit}"
+
+ cd "${S}"
+ emake kpathsea_dir="/usr/include/kpathsea" texmf="${TEXMF_PATH}" || die
+ use emacs && elisp-compile xdvi-search.el
+}
+
+src_install() {
+ einstall kpathsea_dir="/usr/include/kpathsea" texmf="${D}${TEXMF_PATH}" || die "install failed"
+
+ dodir /etc/texmf/xdvi /etc/X11/app-defaults
+ mv "${D}${TEXMF_PATH}/xdvi/XDvi" "${D}etc/X11/app-defaults" || die "failed to move config file"
+ dosym {/etc/X11/app-defaults,"${TEXMF_PATH}/xdvi"}/XDvi || die "failed to symlink config file"
+ for i in $(find "${D}${TEXMF_PATH}/xdvi" -type f -maxdepth 1) ; do
+ mv ${i} "${D}etc/texmf/xdvi" || die "failed to move $i"
+ dosym {/etc/texmf,"${TEXMF_PATH}"}/xdvi/$(basename ${i}) || die "failed to symlink $i"
+ done
+
+ dodoc BUGS FAQ README.* || die "dodoc failed"
+
+ use emacs && elisp-install tex-utils *.el *.elc
+
+ doicon "${FILESDIR}/${PN}.png"
+ make_desktop_entry xdvi "XDVI" xdvik "Graphics;Viewer"
+ echo "MimeType=application/x-dvi;" >> "${D}"usr/share/applications/xdvi-"${PN}".desktop
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elog "Add"
+ elog " (add-to-list 'load-path \"${SITELISP}/tex-utils\")"
+ elog " (require 'xdvi-search)"
+ elog "to your ~/.emacs file"
+ fi
+}