summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-19 05:32:13 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-19 05:32:13 +0000
commit2bfa46557c66881b6fc89da93d5284bed2ebc7a8 (patch)
treefbbcc27ecaf2aba0e7296491ba1bc3071f51000d /app-vim/fugitive
parentsci-physics/lammps-20140614: Version bump. (diff)
downloadgentoo-2-2bfa46557c66881b6fc89da93d5284bed2ebc7a8.tar.gz
gentoo-2-2bfa46557c66881b6fc89da93d5284bed2ebc7a8.tar.bz2
gentoo-2-2bfa46557c66881b6fc89da93d5284bed2ebc7a8.zip
Version bump and add live ebuild.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/ChangeLog11
-rw-r--r--app-vim/fugitive/fugitive-2.0_beta.ebuild17
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild17
3 files changed, 43 insertions, 2 deletions
diff --git a/app-vim/fugitive/ChangeLog b/app-vim/fugitive/ChangeLog
index 84c8c7482bd7..e91a263149fb 100644
--- a/app-vim/fugitive/ChangeLog
+++ b/app-vim/fugitive/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/fugitive
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/ChangeLog,v 1.6 2013/12/24 12:44:04 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/ChangeLog,v 1.7 2014/06/19 05:32:13 radhermit Exp $
+
+*fugitive-9999 (19 Jun 2014)
+*fugitive-2.0_beta (19 Jun 2014)
+
+ 19 Jun 2014; Tim Harder <radhermit@gentoo.org> +fugitive-2.0_beta.ebuild,
+ +fugitive-9999.ebuild:
+ Version bump and add live ebuild.
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> fugitive-1.2.ebuild:
Stable for x86, wrt bug #481862
diff --git a/app-vim/fugitive/fugitive-2.0_beta.ebuild b/app-vim/fugitive/fugitive-2.0_beta.ebuild
new file mode 100644
index 000000000000..865a54705232
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.0_beta.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/fugitive-2.0_beta.ebuild,v 1.1 2014/06/19 05:32:13 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+SRC_URI="https://github.com/tpope/vim-fugitive/archive/v2.0.beta.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
new file mode 100644
index 000000000000..d340b2fdca0e
--- /dev/null
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fugitive/fugitive-9999.ebuild,v 1.1 2014/06/19 05:32:13 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin git-r3
+
+EGIT_REPO_URI="git://github.com/tpope/vim-fugitive.git"
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"