summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-10-31 04:10:20 +0000
committerAron Griffis <agriffis@gentoo.org>2003-10-31 04:10:20 +0000
commit38c3f781d28716a469f567477ab5eb8acf30400f (patch)
tree25cd21ce20fb7ead6dda6169cc40e45f18cbcdc0 /app-vim
parentadd latexsuite for bug 30285 (diff)
downloadgentoo-2-38c3f781d28716a469f567477ab5eb8acf30400f.tar.gz
gentoo-2-38c3f781d28716a469f567477ab5eb8acf30400f.tar.bz2
gentoo-2-38c3f781d28716a469f567477ab5eb8acf30400f.zip
add latexsuite for bug 30285
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/latexsuite/ChangeLog11
-rw-r--r--app-vim/latexsuite/Manifest4
-rw-r--r--app-vim/latexsuite/files/digest-latexsuite-1.5_rc11
-rw-r--r--app-vim/latexsuite/latexsuite-1.5_rc1.ebuild36
-rw-r--r--app-vim/latexsuite/metadata.xml5
5 files changed, 56 insertions, 1 deletions
diff --git a/app-vim/latexsuite/ChangeLog b/app-vim/latexsuite/ChangeLog
new file mode 100644
index 000000000000..540451858a84
--- /dev/null
+++ b/app-vim/latexsuite/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-vim/latexsuite
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/latexsuite/ChangeLog,v 1.1 2003/10/31 04:10:16 agriffis Exp $
+
+*latexsuite-1.5_rc1 (30 Oct 2003)
+
+ 30 Oct 2003; Aron Griffis <agriffis@gentoo.org> latexsuite-1.5_rc1.ebuild,
+ metadata.xml:
+ Add latexsuite to app-vim. Thanks to Bjorn Michaelsen in bug 30285 for the
+ ebuild.
+
diff --git a/app-vim/latexsuite/Manifest b/app-vim/latexsuite/Manifest
index 026e74919904..38be4450704d 100644
--- a/app-vim/latexsuite/Manifest
+++ b/app-vim/latexsuite/Manifest
@@ -1,2 +1,4 @@
-MD5 702751c43dd84cfa29cde59088b7c402 latexsuite-1.5_rc1.ebuild 999
+MD5 145c46105e79a0660ac8cf6ebcc2a32f latexsuite-1.5_rc1.ebuild 1182
+MD5 e74c3b088ea10d3812e4b2f51f5f0a44 ChangeLog 436
+MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
MD5 c8849f310e180a58ea74d06c7180870d files/digest-latexsuite-1.5_rc1 70
diff --git a/app-vim/latexsuite/files/digest-latexsuite-1.5_rc1 b/app-vim/latexsuite/files/digest-latexsuite-1.5_rc1
new file mode 100644
index 000000000000..0f92622512d9
--- /dev/null
+++ b/app-vim/latexsuite/files/digest-latexsuite-1.5_rc1
@@ -0,0 +1 @@
+MD5 6f383971bd6552403b234f61ae8ddd55 latexSuite-1.5-rc1.tar.gz 188634
diff --git a/app-vim/latexsuite/latexsuite-1.5_rc1.ebuild b/app-vim/latexsuite/latexsuite-1.5_rc1.ebuild
new file mode 100644
index 000000000000..9c5d8f6d6674
--- /dev/null
+++ b/app-vim/latexsuite/latexsuite-1.5_rc1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/latexsuite/latexsuite-1.5_rc1.ebuild,v 1.1 2003/10/31 04:10:16 agriffis Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Latex-Suite attempts to provide a comprehensive set of tools to view, edit and compile LaTeX documents in Vim."
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+LICENSE="vim"
+KEYWORDS="~alpha ~sparc ~x86"
+
+# We use this tar-ball as it's distributed instead of repackaging it.
+# The only caveat is that the tarball unpacks into the current
+# directory instead of including a top-level directory.
+MY_P="latexSuite-${PV/_/-}"
+S="${WORKDIR}"
+SRC_URI="http://vim-latex.sourceforge.net/download/${MY_P}.tar.gz"
+
+RDEPEND="app-text/tetex"
+
+src_install() {
+ into /usr ; dobin ltags ; rm ltags
+ vim-plugin_src_install
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ einfo ""
+ einfo "To use the latexSuite plugin add:"
+ einfo " filetype plugin on"
+ einfo " set grepprg=grep\ -nH\ $*"
+ einfo "to your ~/.vimrc-file"
+ einfo ""
+ einfo "Help for this plugin is available with ':help latex-suite' in vim"
+ einfo ""
+}
diff --git a/app-vim/latexsuite/metadata.xml b/app-vim/latexsuite/metadata.xml
new file mode 100644
index 000000000000..5fcb67350f69
--- /dev/null
+++ b/app-vim/latexsuite/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+</pkgmetadata>