summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-05-05 17:44:36 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-05-05 17:44:36 +0000
commit54299441f5d65435aabdbac9b645648570fdc7e8 (patch)
treeb4f604c9f6fe261d55ff13619805682a79dbb0b3 /app-vim
parentRemoving old version. (diff)
downloadgentoo-2-54299441f5d65435aabdbac9b645648570fdc7e8.tar.gz
gentoo-2-54299441f5d65435aabdbac9b645648570fdc7e8.tar.bz2
gentoo-2-54299441f5d65435aabdbac9b645648570fdc7e8.zip
New version. Seems to play a bit nicer with vim7.
(Portage version: 2.0.51.21)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/taglist/ChangeLog8
-rw-r--r--app-vim/taglist/Manifest4
-rw-r--r--app-vim/taglist/files/digest-taglist-4.0_beta11
-rw-r--r--app-vim/taglist/taglist-4.0_beta1.ebuild24
4 files changed, 35 insertions, 2 deletions
diff --git a/app-vim/taglist/ChangeLog b/app-vim/taglist/ChangeLog
index b9c48073fc95..92df2c5bd76e 100644
--- a/app-vim/taglist/ChangeLog
+++ b/app-vim/taglist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/taglist
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/taglist/ChangeLog,v 1.37 2005/03/20 14:27:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/taglist/ChangeLog,v 1.38 2005/05/05 17:44:36 ciaranm Exp $
+
+*taglist-4.0_beta1 (05 May 2005)
+
+ 05 May 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +taglist-4.0_beta1.ebuild:
+ New version. Seems to play a bit nicer with vim7.
20 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> taglist-3.4-r1.ebuild:
ppc-macos needs deps first
diff --git a/app-vim/taglist/Manifest b/app-vim/taglist/Manifest
index 38883580431e..8fbded0d3605 100644
--- a/app-vim/taglist/Manifest
+++ b/app-vim/taglist/Manifest
@@ -2,7 +2,9 @@ MD5 913d104b1e1551310c012762bb584746 ChangeLog 4369
MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
MD5 69a449f44ab805c619cd24346891b097 taglist-3.4-r1.ebuild 586
MD5 5cc5a9d33b96a8aa2d45b34429ea5158 taglist-3.4.ebuild 504
+MD5 48782eb89a6dec8a6f62a9fdc7c4417f taglist-4.0_beta1.ebuild 658
MD5 6c7387e0d96db70dfc803f7cfd973a1e files/digest-taglist-3.4 63
-MD5 c7f319a44a948c29f40f341c69126fd9 files/taglist-2.6-exuberant.patch 349
MD5 6c7387e0d96db70dfc803f7cfd973a1e files/digest-taglist-3.4-r1 63
+MD5 c7f319a44a948c29f40f341c69126fd9 files/taglist-2.6-exuberant.patch 349
MD5 d2c2a2110dd2457af6711f93504ca53c files/taglist-3.4-ebuilds.patch 451
+MD5 618b6a1f4723bd8f4f8420e3f41ed1a1 files/digest-taglist-4.0_beta1 69
diff --git a/app-vim/taglist/files/digest-taglist-4.0_beta1 b/app-vim/taglist/files/digest-taglist-4.0_beta1
new file mode 100644
index 000000000000..9b5873149c01
--- /dev/null
+++ b/app-vim/taglist/files/digest-taglist-4.0_beta1
@@ -0,0 +1 @@
+MD5 60075bea24273e4b992d29f66cf622db taglist-4.0_beta1.tar.bz2 30585
diff --git a/app-vim/taglist/taglist-4.0_beta1.ebuild b/app-vim/taglist/taglist-4.0_beta1.ebuild
new file mode 100644
index 000000000000..4530bd0dffee
--- /dev/null
+++ b/app-vim/taglist/taglist-4.0_beta1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/taglist/taglist-4.0_beta1.ebuild,v 1.1 2005/05/05 17:44:36 ciaranm Exp $
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: ctags-based source code browser"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=273"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="taglist-intro"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-3.4-ebuilds.patch
+ [[ -f plugin/${PN}.vim.orig ]] && rm plugin/${PN}.vim.orig
+}
+