summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-12-05 10:51:49 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-12-05 10:51:49 +0000
commit47a3a4151de6c94aacebfb332fac0ac3feb1b865 (patch)
treed3cd20fbc282f59008153d598c5b81c6a874244d /dev-cpp/commoncpp2/commoncpp2-1.3.0.ebuild
parentfix src_uri for amd64 (Manifest recommit) (diff)
downloadgentoo-2-47a3a4151de6c94aacebfb332fac0ac3feb1b865.tar.gz
gentoo-2-47a3a4151de6c94aacebfb332fac0ac3feb1b865.tar.bz2
gentoo-2-47a3a4151de6c94aacebfb332fac0ac3feb1b865.zip
version bump; mark1.2.5 stable
Diffstat (limited to 'dev-cpp/commoncpp2/commoncpp2-1.3.0.ebuild')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.3.0.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.3.0.ebuild
new file mode 100644
index 000000000000..b6d0f9b882cb
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.3.0.ebuild,v 1.1 2004/12/05 10:51:49 lanius Exp $
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+SRC_URI="mirror://sourceforge/cplusplus/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commoncpp/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc xml2"
+
+DEPEND="xml2? ( dev-libs/libxml2 )"
+
+src_compile() {
+ use xml2 \
+ && myconf="${myconf} --with-xml" \
+ || myconf="${myconf} --without-xml"
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ THANKS TODO COPYING COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml doc/html/*
+}