summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-28 14:18:09 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-28 14:18:09 +0000
commitf9b6d8a827fee0a1e64d3efd3e6216700256e307 (patch)
tree700ff7aa9d6eaaec870762c3930f6f7d8eed2d3b /dev-cpp/gtkmm
parentAIX port of source: use sys-devel/gnulib for getopt. (diff)
downloadgentoo-2-f9b6d8a827fee0a1e64d3efd3e6216700256e307.tar.gz
gentoo-2-f9b6d8a827fee0a1e64d3efd3e6216700256e307.tar.bz2
gentoo-2-f9b6d8a827fee0a1e64d3efd3e6216700256e307.zip
Fix build with USE=doc due to mm-common/glibmm changes
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gtkmm')
-rw-r--r--dev-cpp/gtkmm/ChangeLog5
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.24.0.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/dev-cpp/gtkmm/ChangeLog b/dev-cpp/gtkmm/ChangeLog
index 6c61ad41a66d..908efa0821b4 100644
--- a/dev-cpp/gtkmm/ChangeLog
+++ b/dev-cpp/gtkmm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/gtkmm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.195 2011/03/26 19:57:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.196 2011/03/28 14:18:09 nirbheek Exp $
+
+ 28 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gtkmm-2.24.0.ebuild:
+ Fix build with USE=doc due to mm-common/glibmm changes
*gtkmm-2.24.0 (26 Mar 2011)
diff --git a/dev-cpp/gtkmm/gtkmm-2.24.0.ebuild b/dev-cpp/gtkmm/gtkmm-2.24.0.ebuild
index 2c1795997439..aac1df3bfced 100644
--- a/dev-cpp/gtkmm/gtkmm-2.24.0.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.24.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.24.0.ebuild,v 1.1 2011/03/26 19:57:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.24.0.ebuild,v 1.2 2011/03/28 14:18:09 nirbheek Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -24,19 +24,18 @@ RDEPEND=">=dev-cpp/glibmm-2.24:2
DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? (
+ >=dev-cpp/mm-common-0.9.3
media-gfx/graphviz
dev-libs/libxslt
app-doc/doxygen )"
-pkg_setup() {
+src_prepare() {
DOCS="AUTHORS ChangeLog PORTING NEWS README"
G2CONF="${G2CONF}
--enable-api-atkmm
--disable-maintainer-mode
$(use_enable doc documentation)"
-}
-src_prepare() {
gnome2_src_prepare
if ! use test; then
@@ -50,4 +49,11 @@ src_prepare() {
sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed 2 failed"
fi
+
+ if use doc; then
+ # Needed till upstream re-generates the tarball with mm-common-0.9.3
+ # glibmm no longer ships doc-install.pl, and the macro changed
+ mm-common-prepare --copy --force
+ eautoreconf
+ fi
}