summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-20 19:17:39 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-20 19:17:39 +0000
commite2901e9ffac69cb0613a2a1be22cea213e9ea978 (patch)
treec29393f5c6e7167764364d93c10ab38d9bf5030d /dev-cpp/libassa
parentAdd neon USE flag to enable SIMD optimisations on ARM. (diff)
downloadgentoo-2-e2901e9ffac69cb0613a2a1be22cea213e9ea978.tar.gz
gentoo-2-e2901e9ffac69cb0613a2a1be22cea213e9ea978.tar.bz2
gentoo-2-e2901e9ffac69cb0613a2a1be22cea213e9ea978.zip
Made building of static libraries optional and removed .la files
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/libassa')
-rw-r--r--dev-cpp/libassa/ChangeLog5
-rw-r--r--dev-cpp/libassa/libassa-3.5.0.ebuild15
2 files changed, 14 insertions, 6 deletions
diff --git a/dev-cpp/libassa/ChangeLog b/dev-cpp/libassa/ChangeLog
index 7943e31c50e1..de08345c0718 100644
--- a/dev-cpp/libassa/ChangeLog
+++ b/dev-cpp/libassa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/libassa
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/ChangeLog,v 1.11 2011/02/19 17:11:13 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/ChangeLog,v 1.12 2011/03/20 19:17:39 angelos Exp $
+
+ 20 Mar 2011; Christoph Mende <angelos@gentoo.org> libassa-3.5.0.ebuild:
+ Made building of static libraries optional and removed .la files
19 Feb 2011; <angelos@gentoo.org> libassa-3.5.0.ebuild,
+files/libassa-3.5.0-ldflags.patch:
diff --git a/dev-cpp/libassa/libassa-3.5.0.ebuild b/dev-cpp/libassa/libassa-3.5.0.ebuild
index 0296ab1b9275..03da6e14e105 100644
--- a/dev-cpp/libassa/libassa-3.5.0.ebuild
+++ b/dev-cpp/libassa/libassa-3.5.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/libassa-3.5.0.ebuild,v 1.8 2011/02/19 17:11:13 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libassa/libassa-3.5.0.ebuild,v 1.9 2011/03/20 19:17:39 angelos Exp $
-EAPI=2
+EAPI=3
inherit autotools eutils
DESCRIPTION="A networking library based on Adaptive Communication Patterns"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+IUSE="static-libs"
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc44.patch \
@@ -23,7 +23,12 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+ find "${ED}" -name "*.la" -delete || die "failed to delete .la files"
}