summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-07-22 00:36:18 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-07-22 00:36:18 +0000
commit573b6f8bd7bf1c49cedc400ad0130759842718f4 (patch)
treeb3decd6b4de3d5a483c69cdece78da55db2d8f4b /dev-cpp/libgnomeuimm/libgnomeuimm-2.10.0.ebuild
parentRemove SRC_URI from all gnome-mm packages that set it to ftp.gnome.org... or ... (diff)
downloadgentoo-2-573b6f8bd7bf1c49cedc400ad0130759842718f4.tar.gz
gentoo-2-573b6f8bd7bf1c49cedc400ad0130759842718f4.tar.bz2
gentoo-2-573b6f8bd7bf1c49cedc400ad0130759842718f4.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-cpp/libgnomeuimm/libgnomeuimm-2.10.0.ebuild')
-rw-r--r--dev-cpp/libgnomeuimm/libgnomeuimm-2.10.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/libgnomeuimm/libgnomeuimm-2.10.0.ebuild b/dev-cpp/libgnomeuimm/libgnomeuimm-2.10.0.ebuild
new file mode 100644
index 000000000000..b69e2f6364cc
--- /dev/null
+++ b/dev-cpp/libgnomeuimm/libgnomeuimm-2.10.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomeuimm/libgnomeuimm-2.10.0.ebuild,v 1.1 2005/07/22 00:36:18 ka0ttic Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="C++ bindings for libgnomeui"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=gnome-base/libgnomeui-2.6
+ >=dev-cpp/libgnomemm-2.6
+ >=dev-cpp/libgnomecanvasmm-2.6
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.4
+ >=dev-cpp/gnome-vfsmm-2.6"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS INSTALL TODO"
+
+src_compile() {
+ if useq amd64 || useq ppc64; then
+ aclocal -I scripts
+ automake -c -f
+ autoconf
+ libtoolize --copy --force
+ fi
+
+ gnome2_src_compile
+}