summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-10-14 23:16:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-10-14 23:16:31 +0000
commit139cf5565b917f8701c5c1450f0f26ccce716d19 (patch)
tree8f0b7f4ea1fb6d58ae88b5b270b767d89a72e414 /dev-cpp/libxmlpp/libxmlpp-2.20.0.ebuild
parentVersion bump. Removed superfluous PYTHON_MODULE (diff)
downloadgentoo-2-139cf5565b917f8701c5c1450f0f26ccce716d19.tar.gz
gentoo-2-139cf5565b917f8701c5c1450f0f26ccce716d19.tar.bz2
gentoo-2-139cf5565b917f8701c5c1450f0f26ccce716d19.zip
bump to 2.20.0 and fix some QA warnings
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-cpp/libxmlpp/libxmlpp-2.20.0.ebuild')
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.20.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.20.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.20.0.ebuild
new file mode 100644
index 000000000000..d2519b3fd50a
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.20.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.20.0.ebuild,v 1.1 2007/10/14 23:16:31 eva Exp $
+
+inherit gnome2 eutils
+
+MY_PN="${PN/pp/++}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.1
+ >=dev-cpp/glibmm-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="AUTHORS ChangeLog NEWS README*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+ dosed -i 's|^\(Cflags.*-I.* \)-I.*$|\1|' \
+ /usr/$(get_libdir)/pkgconfig/${MY_PN}-${SLOT}.pc
+
+ rm -fr "${D}"/usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/${PV%.*}/html/*
+}