summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2009-02-20 07:59:28 +0000
committerIlya Volynets <iluxa@gentoo.org>2009-02-20 07:59:28 +0000
commit2549a788d09113f77eb8ef56677fac478809fa69 (patch)
treef742ed8952f6878f6cb205af0138ba83439be75f /dev-cpp
parentfix bug 259633, thanks to Ryan Hill (diff)
downloadgentoo-2-2549a788d09113f77eb8ef56677fac478809fa69.tar.gz
gentoo-2-2549a788d09113f77eb8ef56677fac478809fa69.tar.bz2
gentoo-2-2549a788d09113f77eb8ef56677fac478809fa69.zip
Add SPTK-3.5.8.10
(Portage version: 2.1.6.4/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.10.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index c1f4b8431d34..aa31865ce7bc 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.50 2009/02/15 17:20:16 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.51 2009/02/20 07:59:28 iluxa Exp $
+
+*sptk-3.5.8.10 (20 Feb 2009)
+
+ 20 Feb 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.8.10.ebuild:
+ Add SPTK-3.5.8.10
15 Feb 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
sptk-3.5.8.9.ebuild:
diff --git a/dev-cpp/sptk/sptk-3.5.8.10.ebuild b/dev-cpp/sptk/sptk-3.5.8.10.ebuild
new file mode 100644
index 000000000000..a65078090f72
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.8.10.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2006-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.10.ebuild,v 1.1 2009/02/20 07:59:28 iluxa Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic multilib
+
+IUSE="fltk odbc doc sqlite examples excel postgres aspell mysql"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite? ( >=dev-db/sqlite-3 )
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ mysql? ( dev-db/mysql )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
+ doc? ( app-doc/doxygen )"
+
+sptk_use_enable() {
+ if use ${1}; then
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
+ else
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sptk_use_enable examples EXAMPLES
+ sptk_use_enable postgres POSTGRESQL
+ sptk_use_enable mysql MYSQL
+ sptk_use_enable sqlite3 SQLITE3
+ sptk_use_enable odbc ODBC
+ sptk_use_enable aspell ASPELL
+ sptk_use_enable fltk FLTK
+ sptk_use_enable excel EXCEL
+
+ cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} . || die "Configuration Failed"
+}
+
+src_compile() {
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}