summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-16 04:36:49 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-16 04:36:49 +0000
commit90cdcd001e6f1d1b622967cb9c0a473585347f12 (patch)
tree532c580bebea057092f73d47e513d89c9167ee95 /dev-db/freetds
parentadded keywords (diff)
downloadgentoo-2-90cdcd001e6f1d1b622967cb9c0a473585347f12.tar.gz
gentoo-2-90cdcd001e6f1d1b622967cb9c0a473585347f12.tar.bz2
gentoo-2-90cdcd001e6f1d1b622967cb9c0a473585347f12.zip
New package. Fixes #3847. Thanks to Jerry Haltom
Diffstat (limited to 'dev-db/freetds')
-rw-r--r--dev-db/freetds/ChangeLog15
-rw-r--r--dev-db/freetds/files/digest-freetds-0.531
-rw-r--r--dev-db/freetds/freetds-0.53.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/freetds/ChangeLog b/dev-db/freetds/ChangeLog
new file mode 100644
index 000000000000..2633d1c7efe4
--- /dev/null
+++ b/dev-db/freetds/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-db/freetds
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-db/freetds/ChangeLog,v 1.1 2002/07/16 04:36:49 rphillips Exp $
+
+*freetds-0.53 (15 Jul 2002)
+
+ 15 Jul 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Submitted by Jerry Haltom
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-db/freetds/files/digest-freetds-0.53 b/dev-db/freetds/files/digest-freetds-0.53
new file mode 100644
index 000000000000..b1ae0f48fcf5
--- /dev/null
+++ b/dev-db/freetds/files/digest-freetds-0.53
@@ -0,0 +1 @@
+MD5 78586f3db87f53a8097d7665a4d8f892 freetds-0.53.tgz 312692
diff --git a/dev-db/freetds/freetds-0.53.ebuild b/dev-db/freetds/freetds-0.53.ebuild
new file mode 100644
index 000000000000..495b9904ceab
--- /dev/null
+++ b/dev-db/freetds/freetds-0.53.ebuild
@@ -0,0 +1,43 @@
+#Copyright 2002 Gentoo Technologies, Inc.
+#Distributed under the terms of the GNU General Public License, v2 or later
+#Author <root@station-1.internal.feedbackplusinc.com>
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="Tabular Datastream Library"
+SRC_URI="http://ibiblio.org/pub/Linux/ALPHA/freetds/${P}.tgz"
+HOMEPAGE="http://ibiblio.org/pub/Linux/ALPHA/freetds/"
+DEPEND="virtual/glibc"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+
+ unpack ${P}.tgz
+ cd ${S}
+
+}
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-tdsver=7.0 \
+ || die "./configure failed"
+
+ emake || die
+
+ mv ${S}/Makefile ${S}/Makefile.orig
+ sed -e 's/^DEFDIR = /DEFDIR = $(DESTDIR)/' \
+ -e 's/^ETC = /ETC = $(DESTDIR)/' \
+ ${S}/Makefile.orig > ${S}/Makefile
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+}
+
+
+