summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-03-16 09:34:33 +0000
committerPeter Volkov <pva@gentoo.org>2007-03-16 09:34:33 +0000
commit695302a4e0da283765afb22b13e4faf45452ec2d (patch)
treee9ec39b039d2918782767ec48ef45370b57726d2 /dev-db/gigabase
parentRelease candidate for OpenOffice.org 2.2.0 (diff)
downloadgentoo-2-695302a4e0da283765afb22b13e4faf45452ec2d.tar.gz
gentoo-2-695302a4e0da283765afb22b13e4faf45452ec2d.tar.bz2
gentoo-2-695302a4e0da283765afb22b13e4faf45452ec2d.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-db/gigabase')
-rw-r--r--dev-db/gigabase/ChangeLog7
-rw-r--r--dev-db/gigabase/files/digest-gigabase-3.563
-rw-r--r--dev-db/gigabase/gigabase-3.56.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index 81a00e19927d..89181982c162 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.20 2007/02/27 15:22:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.21 2007/03/16 09:34:33 pva Exp $
+
+*gigabase-3.56 (16 Mar 2007)
+
+ 16 Mar 2007; <pva@gentoo.org> +gigabase-3.56.ebuild:
+ Version bump.
27 Feb 2007; Raúl Porcel <armin76@gentoo.org> gigabase-3.54.ebuild:
x86 stable wrt bug 168564
diff --git a/dev-db/gigabase/files/digest-gigabase-3.56 b/dev-db/gigabase/files/digest-gigabase-3.56
new file mode 100644
index 000000000000..69c99e8dfda4
--- /dev/null
+++ b/dev-db/gigabase/files/digest-gigabase-3.56
@@ -0,0 +1,3 @@
+MD5 baa2cb8f8efa7da4073320a143267ac8 gigabase-3.56.tar.gz 1419071
+RMD160 f7b63634f9461317e4b47cde2cb77d4e39705791 gigabase-3.56.tar.gz 1419071
+SHA256 00807759d81858cff6d64060e7a258d157a933b535a038ef13d291df6e7ae11e gigabase-3.56.tar.gz 1419071
diff --git a/dev-db/gigabase/gigabase-3.56.ebuild b/dev-db/gigabase/gigabase-3.56.ebuild
new file mode 100644
index 000000000000..ecf616fbf59a
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.56.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.56.ebuild,v 1.1 2007/03/16 09:34:33 pva Exp $
+
+inherit multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+DEPEND=""
+
+S="${WORKDIR}"/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}