summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-08-28 10:40:39 +0000
committerPeter Volkov <pva@gentoo.org>2006-08-28 10:40:39 +0000
commitafac3b45bde78d5f01921edc576d12f2e56f75c9 (patch)
tree7df4697c6300ba718dd200948a98591a2bf02e12 /dev-db/gigabase
parentHandle single-threaded check for X server. Bug #144665. (diff)
downloadgentoo-2-afac3b45bde78d5f01921edc576d12f2e56f75c9.tar.gz
gentoo-2-afac3b45bde78d5f01921edc576d12f2e56f75c9.tar.bz2
gentoo-2-afac3b45bde78d5f01921edc576d12f2e56f75c9.zip
Version bump. Thank Joshua Jackson for report (bug #103010). Also fixed bug #131076 and added ~amd64 KEYWORD.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-db/gigabase')
-rw-r--r--dev-db/gigabase/ChangeLog11
-rw-r--r--dev-db/gigabase/files/digest-gigabase-3.513
-rw-r--r--dev-db/gigabase/gigabase-3.51.ebuild44
-rw-r--r--dev-db/gigabase/metadata.xml23
4 files changed, 79 insertions, 2 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index e2fa78369154..bb60d1963a37 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/gigabase
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.11 2005/08/27 20:19:52 rphillips Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.12 2006/08/28 10:40:39 pva Exp $
+
+*gigabase-3.51 (28 Aug 2006)
+
+ 28 Aug 2006; Peter Volkov <pva@gentoo.org> metadata.xml,
+ +gigabase-3.51.ebuild:
+ Version bump. Thank Joshua Jackson for report (bug #103010). Also fixed bug
+ #131076 and added ~amd64 KEYWORD.
*gigabase-3.41 (27 Aug 2005)
diff --git a/dev-db/gigabase/files/digest-gigabase-3.51 b/dev-db/gigabase/files/digest-gigabase-3.51
new file mode 100644
index 000000000000..839d483fa28d
--- /dev/null
+++ b/dev-db/gigabase/files/digest-gigabase-3.51
@@ -0,0 +1,3 @@
+MD5 74d63595a05647967985db0a0d170b8c gigabase-3.51.tar.gz 1536316
+RMD160 6b6a6f836545a75ed6bce88f107505af0a61ca2e gigabase-3.51.tar.gz 1536316
+SHA256 a2a99e67abd078e468f6c4e191ee4ab5e78d9423ee562ca5034b5c69183bfc1e gigabase-3.51.tar.gz 1536316
diff --git a/dev-db/gigabase/gigabase-3.51.ebuild b/dev-db/gigabase/gigabase-3.51.ebuild
new file mode 100644
index 000000000000..14108026ef27
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.51.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.51.ebuild,v 1.1 2006/08/28 10:40:39 pva Exp $
+
+inherit multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~s390 ~amd64"
+IUSE="doc"
+DEPEND=""
+
+S="${WORKDIR}"/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}
diff --git a/dev-db/gigabase/metadata.xml b/dev-db/gigabase/metadata.xml
index 20ce219711a2..314f32c6f41c 100644
--- a/dev-db/gigabase/metadata.xml
+++ b/dev-db/gigabase/metadata.xml
@@ -2,4 +2,27 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>no-herd</herd>
+ <maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+ </maintainer>
+ <longdescription lang="en">
+ Object-Relational Database Management System GigaBASE inherits most of the
+ features of FastDB, but uses page pool instead of direct mapping of file on
+ virtual memory. So GigaBASE is able to handle database, which size
+ significantly exceeds size of computer physical memory. Convenient and
+ flexible C++ interface makes development of application for GigaBASE very
+ easy and automatic scheme evaluation simplifies maintenance and modification
+ of the system. GigaBASE merges best features of relational (simple data
+ structure and non-procedural query language) and object-oriented (direct
+ object references, user defined types and methods) databases. GigaBASE is
+ primary oriented on application requiring fast data retrieving by means of
+ indices and direct object references, such as Web Server databases
+ applications. SUBSQL utility can be used for database browsing and
+ inspection, performing online backups, database recovery, importing data to
+ and exporting data from database. GigaBASE will perform automatic recovery
+ after system or application crash, you should not worry about it. The only
+ thing you can have to do manually is stopping all database application if
+ one of them is crashed leaving database blocked.
+ </longdescription>
</pkgmetadata>