summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-08-26 09:42:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-08-26 09:42:59 +0000
commit20a978f158278ae67ea8f96ea8dcf27b0b2f9154 (patch)
treef218e2a3fd2aa937436ee0386818fa826ad0b554 /dev-db/hyperdex
parentAdded ~mips to KEYWORDS. (diff)
downloadgentoo-2-20a978f158278ae67ea8f96ea8dcf27b0b2f9154.tar.gz
gentoo-2-20a978f158278ae67ea8f96ea8dcf27b0b2f9154.tar.bz2
gentoo-2-20a978f158278ae67ea8f96ea8dcf27b0b2f9154.zip
Bump
(Portage version: 2.2.12/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/hyperdex')
-rw-r--r--dev-db/hyperdex/ChangeLog7
-rw-r--r--dev-db/hyperdex/hyperdex-1.4.3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-db/hyperdex/ChangeLog b/dev-db/hyperdex/ChangeLog
index f60bda1083a2..a40706700da5 100644
--- a/dev-db/hyperdex/ChangeLog
+++ b/dev-db/hyperdex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/hyperdex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.23 2014/08/25 06:31:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/ChangeLog,v 1.24 2014/08/26 09:42:59 patrick Exp $
+
+*hyperdex-1.4.3 (26 Aug 2014)
+
+ 26 Aug 2014; Patrick Lauer <patrick@gentoo.org> +hyperdex-1.4.3.ebuild:
+ Bump
*hyperdex-1.4.2 (25 Aug 2014)
diff --git a/dev-db/hyperdex/hyperdex-1.4.3.ebuild b/dev-db/hyperdex/hyperdex-1.4.3.ebuild
new file mode 100644
index 000000000000..d58f76f7b510
--- /dev/null
+++ b/dev-db/hyperdex/hyperdex-1.4.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hyperdex/hyperdex-1.4.3.ebuild,v 1.1 2014/08/26 09:42:59 patrick Exp $
+EAPI=5
+
+PYTHON_COMPAT=( python2_7)
+inherit eutils python-r1 autotools
+
+DESCRIPTION="A searchable distributed Key-Value Store"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz
+ http://dev.gentooexperimental.org/~patrick/autotools-java.tar"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+python"
+# need to add ruby and java useflags too
+
+DEPEND="dev-cpp/glog
+ dev-cpp/sparsehash
+ dev-libs/cityhash
+ dev-libs/libpo6
+ dev-libs/libe
+ dev-libs/busybee
+ dev-libs/popt
+ dev-libs/replicant
+ dev-libs/json-c"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp "${WORKDIR}/"*.m4 m4/
+ sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
+ eautoreconf
+}
+src_configure() {
+ econf --disable-static \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ newinitd "${FILESDIR}/hyperdex.initd" hyperdex || die "Failed to install init script"
+ newconfd "${FILESDIR}/hyperdex.confd" hyperdex || die "Failed to install config file"
+ find "${D}" -name '*.la' -exec rm {} \; # bad buildsystem! bad!
+}