summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:43:48 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:43:48 +0000
commitde6f8613a14be0c55970db814e15936b3c31d819 (patch)
treeefa430e4d57da3058d0b56f7b0fb31f0075e506e /dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
parentRemove old. (diff)
downloadgentoo-2-de6f8613a14be0c55970db814e15936b3c31d819.tar.gz
gentoo-2-de6f8613a14be0c55970db814e15936b3c31d819.tar.bz2
gentoo-2-de6f8613a14be0c55970db814e15936b3c31d819.zip
Conditionalize static lib creation and prune the .la file.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild')
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
index 526303032482..77199fd5dfc6 100644
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild,v 1.2 2012/09/13 18:41:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3-r2.ebuild,v 1.3 2012/09/13 18:43:48 scarabeus Exp $
EAPI=4
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
LICENSE="LGPL-2.1"
-IUSE="bindist doc firebird mysql oci8 postgres +sqlite"
+IUSE="bindist doc firebird mysql oci8 postgres +sqlite static-libs"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
SLOT=0
@@ -65,6 +65,7 @@ src_configure() {
econf \
$(use_enable doc docs) \
+ $(use_enable static-libs static) \
${myconf}
}
@@ -77,3 +78,9 @@ src_test() {
einfo "Running interactive tests"
emake check
}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}