summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-28 01:09:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-28 01:09:25 +0000
commitf4fc6f662d5e7e3e8cbef12c79eca7fe4e463bbe (patch)
tree95a43b0c067a8db4c3a1767e2319b24400bc2c9b /dev-db/libdbi/libdbi-0.7.2-r1.ebuild
parentInitial import. Ebuild by me. (diff)
downloadgentoo-2-f4fc6f662d5e7e3e8cbef12c79eca7fe4e463bbe.tar.gz
gentoo-2-f4fc6f662d5e7e3e8cbef12c79eca7fe4e463bbe.tar.bz2
gentoo-2-f4fc6f662d5e7e3e8cbef12c79eca7fe4e463bbe.zip
Add metadata, cleanup ebuild.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-db/libdbi/libdbi-0.7.2-r1.ebuild')
-rw-r--r--dev-db/libdbi/libdbi-0.7.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-db/libdbi/libdbi-0.7.2-r1.ebuild b/dev-db/libdbi/libdbi-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..071696cd0a08
--- /dev/null
+++ b/dev-db/libdbi/libdbi-0.7.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/libdbi-0.7.2-r1.ebuild,v 1.1 2005/03/28 01:08:41 robbat2 Exp $
+
+DESCRIPTION="libdbi implements a database-independent abstraction layer in C, similar to the DBI/DBD layer in Perl."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+LICENSE="LGPL-2.1"
+RDEPEND="virtual/libc"
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+PDEPEND="dev-db/libdbi-drivers"
+IUSE=""
+KEYWORDS="~x86 ~ppc ~amd64"
+SLOT=0
+
+src_compile() {
+ # should append CFLAGS, not replace them
+ sed -i.orig -e 's/^CFLAGS = /CFLAGS += /g' src/Makefile.in
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING README README.osx TODO
+}