summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-03-08 07:05:30 +0000
committerLance Albertson <ramereth@gentoo.org>2010-03-08 07:05:30 +0000
commitbfff6a1c3141a2b7b03cb5f42458840e74a9c1bf (patch)
treeb441c455f1ed560adab247bd56e3d7b94e301a64 /dev-db/mongodb
parentAdd mask for =dev-db/mongodb-1.3* for development branch (diff)
downloadgentoo-2-bfff6a1c3141a2b7b03cb5f42458840e74a9c1bf.tar.gz
gentoo-2-bfff6a1c3141a2b7b03cb5f42458840e74a9c1bf.tar.bz2
gentoo-2-bfff6a1c3141a2b7b03cb5f42458840e74a9c1bf.zip
Version bump, add 1.3.x branch ebuild, remove postinst bits, use correct upstream tarball.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/mongodb')
-rw-r--r--dev-db/mongodb/ChangeLog11
-rw-r--r--dev-db/mongodb/files/mongodb-1.3-modify-post-strip.patch12
-rw-r--r--dev-db/mongodb/files/mongodb-1.3-modify-testing.patch45
-rw-r--r--dev-db/mongodb/mongodb-1.2.4.ebuild61
-rw-r--r--dev-db/mongodb/mongodb-1.3.3.ebuild61
5 files changed, 189 insertions, 1 deletions
diff --git a/dev-db/mongodb/ChangeLog b/dev-db/mongodb/ChangeLog
index 5fbef23a7f28..c2f50534ac39 100644
--- a/dev-db/mongodb/ChangeLog
+++ b/dev-db/mongodb/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/mongodb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mongodb/ChangeLog,v 1.1 2010/03/07 23:39:41 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mongodb/ChangeLog,v 1.2 2010/03/08 07:05:29 ramereth Exp $
+
+*mongodb-1.3.3 (08 Mar 2010)
+*mongodb-1.2.4 (08 Mar 2010)
+
+ 08 Mar 2010; Lance Albertson <ramereth@gentoo.org> +mongodb-1.2.4.ebuild,
+ +mongodb-1.3.3.ebuild, +files/mongodb-1.3-modify-post-strip.patch,
+ +files/mongodb-1.3-modify-testing.patch:
+ Version bump, add 1.3.x branch ebuild, remove postinst bits, use correct
+ upstream tarball.
*mongodb-1.2.2 (07 Mar 2010)
diff --git a/dev-db/mongodb/files/mongodb-1.3-modify-post-strip.patch b/dev-db/mongodb/files/mongodb-1.3-modify-post-strip.patch
new file mode 100644
index 000000000000..5795c7e48925
--- /dev/null
+++ b/dev-db/mongodb/files/mongodb-1.3-modify-post-strip.patch
@@ -0,0 +1,12 @@
+diff -ur mongodb-src-r1.3.3/SConstruct mongodb-src-r1.3.3.new/SConstruct
+--- mongodb-src-r1.3.3/SConstruct 2010-03-02 07:37:07.000000000 -0800
++++ mongodb-src-r1.3.3.new/SConstruct 2010-03-07 22:36:10.000000000 -0800
+@@ -1478,8 +1478,6 @@
+ fullInstallName = installDir + "/bin/" + name
+
+ allBinaries += [ name ]
+- if (solaris or linux) and (not GetOption("nostrip")):
+- e.AddPostAction( inst, e.Action( 'strip ' + fullInstallName ) )
+
+ if linux and len( COMMAND_LINE_TARGETS ) == 1 and str( COMMAND_LINE_TARGETS[0] ) == "s3dist":
+ e.AddPostAction( inst , checkGlibc )
diff --git a/dev-db/mongodb/files/mongodb-1.3-modify-testing.patch b/dev-db/mongodb/files/mongodb-1.3-modify-testing.patch
new file mode 100644
index 000000000000..b40d59d1459d
--- /dev/null
+++ b/dev-db/mongodb/files/mongodb-1.3-modify-testing.patch
@@ -0,0 +1,45 @@
+diff -ur mongodb-src-r1.3.3/SConstruct mongodb-src-r1.3.3.new/SConstruct
+--- mongodb-src-r1.3.3/SConstruct 2010-03-02 07:37:07.000000000 -0800
++++ mongodb-src-r1.3.3.new/SConstruct 2010-03-07 22:40:02.000000000 -0800
+@@ -1211,15 +1211,17 @@
+ Exit( 1 )
+
+ def ensureTestDirs():
+- ensureDir( "/tmp/unittest/" )
+- ensureDir( "/data/" )
+- ensureDir( "/data/db/" )
++ ensureDir( "testdir/" )
++ ensureDir( "testdir/tmp" )
++ ensureDir( "testdir/tmp/unittest/" )
++ ensureDir( "testdir/data/" )
++ ensureDir( "testdir/data/db/" )
+
+ def testSetup( env , target , source ):
+ ensureTestDirs()
+
+ if len( COMMAND_LINE_TARGETS ) == 1 and str( COMMAND_LINE_TARGETS[0] ) == "test":
+- ensureDir( "/tmp/unittest/" );
++ ensureDir( "testdir/tmp/unittest/" );
+
+ addSmoketest( "smoke", [ add_exe( "test" ) ] , [ test[ 0 ].abspath ] )
+ addSmoketest( "smokePerf", [ "perftest" ] , [ perftest[ 0 ].abspath ] )
+@@ -1297,7 +1299,7 @@
+ mongodForTestsPort = "32000"
+ import os
+ ensureTestDirs()
+- dirName = "/data/db/sconsTests/"
++ dirName = "testdir/data/db/sconsTests/"
+ ensureDir( dirName )
+ from subprocess import Popen
+ mongodForTests = Popen( [ mongod[0].abspath, "--port", mongodForTestsPort, "--dbpath", dirName ] )
+diff -ur mongodb-src-r1.3.3/dbtests/dbtests.cpp mongodb-src-r1.3.3.new/dbtests/dbtests.cpp
+--- mongodb-src-r1.3.3/dbtests/dbtests.cpp 2010-03-02 07:37:07.000000000 -0800
++++ mongodb-src-r1.3.3.new/dbtests/dbtests.cpp 2010-03-07 22:40:37.000000000 -0800
+@@ -22,6 +22,6 @@
+ #include "dbtests.h"
+
+ int main( int argc, char** argv ) {
+- return Suite::run(argc, argv, "/tmp/unittest");
++ return Suite::run(argc, argv, "testdir/tmp/unittest");
+ }
+
diff --git a/dev-db/mongodb/mongodb-1.2.4.ebuild b/dev-db/mongodb/mongodb-1.2.4.ebuild
new file mode 100644
index 000000000000..753a41c28b8e
--- /dev/null
+++ b/dev-db/mongodb/mongodb-1.2.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mongodb/mongodb-1.2.4.ebuild,v 1.1 2010/03/08 07:05:29 ramereth Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PATCHVER=$(get_version_component_range 1-2)
+MY_P="${PN}-src-r${PV}"
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="http://downloads.mongodb.org/src/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/spidermonkey[unicode]
+ dev-libs/boost
+ dev-libs/libpcre"
+
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1.2.0-r1"
+
+# Must change this on every upgrade
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup mongodb
+ enewuser mongodb -1 -1 /var/lib/${PN} mongodb
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${PN}"-"${MY_PATCHVER}"-modify-*.patch
+}
+
+src_compile() {
+ scons ${MAKEOPTS} all || die "Compile failed"
+}
+
+src_install() {
+ scons ${MAKEOPTS} install --prefix="${D}"/usr || die "Install failed"
+
+ for x in /var/{lib,log,run}/${PN}; do
+ dodir "${x}" || die "Install failed"
+ fowners mongodb:mongodb "${x}"
+ done
+
+ doman debian/mongo*.1 || die "Install failed"
+ dodoc README docs/building.md
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die "Install failed"
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die "Install failed"
+}
+
+src_test() {
+ scons ${MAKEOPTS} smoke test || die "Tests failed"
+}
diff --git a/dev-db/mongodb/mongodb-1.3.3.ebuild b/dev-db/mongodb/mongodb-1.3.3.ebuild
new file mode 100644
index 000000000000..5661656f4f3a
--- /dev/null
+++ b/dev-db/mongodb/mongodb-1.3.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mongodb/mongodb-1.3.3.ebuild,v 1.1 2010/03/08 07:05:29 ramereth Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PATCHVER=$(get_version_component_range 1-2)
+MY_P="${PN}-src-r${PV}"
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="http://downloads.mongodb.org/src/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/spidermonkey[unicode]
+ dev-libs/boost
+ dev-libs/libpcre"
+
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1.2.0-r1"
+
+# Must change this on every upgrade
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup mongodb
+ enewuser mongodb -1 -1 /var/lib/${PN} mongodb
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${PN}"-"${MY_PATCHVER}"-modify-*.patch
+}
+
+src_compile() {
+ scons ${MAKEOPTS} all || die "Compile failed"
+}
+
+src_install() {
+ scons ${MAKEOPTS} install --prefix="${D}"/usr || die "Install failed"
+
+ for x in /var/{lib,log,run}/${PN}; do
+ dodir "${x}" || die "Install failed"
+ fowners mongodb:mongodb "${x}"
+ done
+
+ doman debian/mongo*.1 || die "Install failed"
+ dodoc README docs/building.md
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die "Install failed"
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die "Install failed"
+}
+
+src_test() {
+ scons ${MAKEOPTS} smoke test || die "Tests failed"
+}