summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2005-12-26 23:10:57 +0000
committerFrancesco Riosa <vivo@gentoo.org>2005-12-26 23:10:57 +0000
commit3b9e48435e902ee9292a69029e005497483ea189 (patch)
tree1e36ff8601f1949e6cc16fce0becdad7c83c2e27 /dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild
parentmask xen-sources for security (diff)
downloadgentoo-2-3b9e48435e902ee9292a69029e005497483ea189.tar.gz
gentoo-2-3b9e48435e902ee9292a69029e005497483ea189.tar.bz2
gentoo-2-3b9e48435e902ee9292a69029e005497483ea189.zip
fix Bug #116303 dev-db/mysql-5.0.17 ebuild config fails
(Portage version: 2.0.53)
Diffstat (limited to 'dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild b/dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild
index 4cef3aa95d03..ee7916f597ae 100644
--- a/dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild
+++ b/dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild,v 1.1 2005/12/23 17:33:08 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.1.4_alpha-r30.ebuild,v 1.2 2005/12/26 23:10:57 vivo Exp $
# helper function, version (integer) may have section separated by dots
# for readbility
@@ -546,7 +546,7 @@ src_install() {
done
# oops
- mysql_check_version_range "5.00.16.00 to 5.00.16.99" \
+ mysql_check_version_range "5.00.16.00 to 5.00.17.99" \
&& cp "${WORKDIR}/mysql-extras/fill_help_tables.sql-5.0.15" "${D}/usr/share/mysql/"
# TODO change at Makefile-am level
@@ -755,7 +755,7 @@ pkg_config() {
# Filling timezones, see
# http://dev.mysql.com/doc/mysql/en/time-zone-support.html
${ROOT}/usr/bin/mysql_tzinfo_to_sql${MY_SUFFIX} ${ROOT}/usr/share/zoneinfo \
- > "${sqltmp}" 2>&1 | grep -v "Skipping it."
+ > "${sqltmp}" 2>/dev/null
if [[ -r "${help_tables}" ]] ; then
cat "${help_tables}" >> "${sqltmp}"