summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2005-07-10 16:31:42 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2005-07-10 16:31:42 +0000
commitbf6bae3feb15c6dffc8c1779bed3bc266a66462d (patch)
treea9e8ba9a171ac1f60cba9887cfc6f4b4fddcd7e6 /dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild
parentfix deps (diff)
downloadgentoo-2-bf6bae3feb15c6dffc8c1779bed3bc266a66462d.tar.gz
gentoo-2-bf6bae3feb15c6dffc8c1779bed3bc266a66462d.tar.bz2
gentoo-2-bf6bae3feb15c6dffc8c1779bed3bc266a66462d.zip
added unzip depend
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild')
-rw-r--r--dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild b/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild
index 0f7048018de9..09ac46dc3d74 100644
--- a/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild
+++ b/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild,v 1.2 2005/07/09 19:48:20 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-10.1.0.4.ebuild,v 1.3 2005/07/10 16:31:42 radek Exp $
inherit eutils
@@ -18,6 +18,9 @@ KEYWORDS="~x86"
RESTRICT="fetch"
IUSE=""
+DEPEND="app-arch/unzip"
+# RDEPEND does not needs unzip
+
pkg_nofetch() {
eerror "Please go to:"
eerror " ${HOMEPAGE}"
@@ -29,8 +32,8 @@ pkg_nofetch() {
}
src_unpack() {
- unzip ${DISTDIR}/${MY_P}.zip
- unzip ${DISTDIR}/${MY_PSDK}.zip
+ unzip ${DISTDIR}/${MY_P}.zip || die "unsuccesful unzip ${MY_P}.zip"
+ unzip ${DISTDIR}/${MY_PSDK}.zip || die "unsuccesful unzip ${MY_PSDK}.zip"
}
src_install() {