summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2006-12-26 17:59:03 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2006-12-26 17:59:03 +0000
commite0216229a277331f34c04f8ba22b8178322ae397 (patch)
tree916ef1836a15504f9233a28bafb28c71c7c2fb05 /dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.2.0.3.ebuild
parentVersion bump, 10.2.0.3 is only available for x86 as of now. (diff)
downloadgentoo-2-e0216229a277331f34c04f8ba22b8178322ae397.tar.gz
gentoo-2-e0216229a277331f34c04f8ba22b8178322ae397.tar.bz2
gentoo-2-e0216229a277331f34c04f8ba22b8178322ae397.zip
Version bump, 10.2.0.3 is only available for x86 as of now.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.2.0.3.ebuild')
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.2.0.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.2.0.3.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.2.0.3.ebuild
new file mode 100644
index 000000000000..a6189ebc2421
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.2.0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.2.0.3.ebuild,v 1.1 2006/12/26 17:59:03 dertobi123 Exp $
+
+inherit eutils
+
+MY_P_x86="${PN/oracle-/}-linux32-${PV}-20061115"
+
+
+S=${WORKDIR}
+DESCRIPTION="Oracle 10g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://otn.oracle.com/software/tech/oci/instantclient/htdocs/linuxsoft.html"
+SRC_URI="x86? ( ${MY_P_x86}.zip )"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="-* ~x86"
+RESTRICT="fetch"
+IUSE=""
+
+RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ MY_P=MY_P_${ARCH}
+ export MY_P=${!MY_P}
+}
+
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ unzip ${DISTDIR}/${MY_P}.zip
+}
+
+src_install() {
+ dodir /usr/lib/oracle/${PV}/client/lib
+ cd ${S}/instantclient_10_2
+ insinto /usr/lib/oracle/${PV}/client/lib
+ doins libheteroxa10.so orai18n.jar
+}
+
+pkg_postinst() {
+ einfo "The JDBC supplement package for Oracle 10g has been installed."
+ einfo "You may wish to install the oracle-instantclient-sqlplus (for "
+ einfo "running the SQL*Plus application) package as well."
+ einfo
+ einfo "oracle-instantclient-* packages aren't installed in different"
+ einfo "SLOTs any longer. You may want to uninstall older versions."
+}