summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-12 07:24:51 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-12 07:24:51 +0000
commit33aef086e14ec9990a1211eced628e514ec8d09c (patch)
tree874eee9c0599d46f596574dbe3db314796edc4b8 /dev-db/pgadmin3
parentStable on mips. (diff)
downloadgentoo-2-33aef086e14ec9990a1211eced628e514ec8d09c.tar.gz
gentoo-2-33aef086e14ec9990a1211eced628e514ec8d09c.tar.bz2
gentoo-2-33aef086e14ec9990a1211eced628e514ec8d09c.zip
Patch up old ebuild to work with new wxwidgets.eclass changes.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/ChangeLog5
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.2.2.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 99ef07b38cf9..1dbb8ec2517d 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.31 2007/02/10 13:19:10 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.32 2007/05/12 07:24:51 dirtyepic Exp $
+
+ 12 May 2007; Ryan Hill <dirtyepic@gentoo.org> pgadmin3-1.2.2.ebuild:
+ Patch up old ebuild to work with new wxwidgets.eclass changes.
10 Feb 2007; Steve Dibb <beandog@gentoo.org> pgadmin3-1.4.3.ebuild:
amd64 stable, bug 155828
diff --git a/dev-db/pgadmin3/pgadmin3-1.2.2.ebuild b/dev-db/pgadmin3/pgadmin3-1.2.2.ebuild
index fae1c0dac7cc..4a096112c842 100644
--- a/dev-db/pgadmin3/pgadmin3-1.2.2.ebuild
+++ b/dev-db/pgadmin3/pgadmin3-1.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.2.2.ebuild,v 1.7 2005/10/13 22:05:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.2.2.ebuild,v 1.8 2007/05/12 07:24:51 dirtyepic Exp $
inherit eutils libtool wxwidgets
@@ -15,13 +15,13 @@ SLOT="0"
LICENSE="Artistic"
KEYWORDS="alpha amd64 ppc sparc x86"
-DEPEND=">=x11-libs/wxGTK-2.6.0
+DEPEND="=x11-libs/wxGTK-2.6*
dev-db/libpq
>=sys-apps/sed-4"
pkg_setup() {
- if ! built_with_use '>=x11-libs/wxGTK-2.6.0' unicode ; then
- die "${PN} requires >=x11-libs/wxGTK-2.6.0 emerged with USE='unicode'"
+ if ! built_with_use '=x11-libs/wxGTK-2.6*' unicode ; then
+ die "${PN} requires =x11-libs/wxGTK-2.6* emerged with USE='unicode'"
fi
}
@@ -32,15 +32,15 @@ src_unpack() {
}
src_compile() {
- export WX_GTK_VER=2.6
- export WX_HOME=/usr
+ export WX_GTK_VER="2.6"
+ export WX_HOME="/usr"
need-wxwidgets unicode
local myconf
myconf="${myconf} --enable-unicode"
myconf="${myconf} --enable-gtk2"
myconf="${myconf} --with-pgsql-include=/usr/include/postgresql"
- myconf="${myconf} --with-wx-config=/lib/wx/config/${WX_CONFIG_NAME}"
+ myconf="${myconf} --with-wx-config=${WX_CONFIG/\/usr}"
myconf="${myconf} --enable-postgres"
LDFLAGS=-L/usr/lib/postgresql econf ${myconf} || die