summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2011-12-23 21:39:50 +0000
committerAlex Legler <a3li@gentoo.org>2011-12-23 21:39:50 +0000
commit9924623967872297b2979d51507b9081ebccde68 (patch)
tree7424c55ad5428be71c67abe152c0e3b7ac660863 /dev-db/phpmyadmin/phpmyadmin-3.4.9.ebuild
parentStable for AMD64, wrt bug #393827 (diff)
downloadgentoo-2-9924623967872297b2979d51507b9081ebccde68.tar.gz
gentoo-2-9924623967872297b2979d51507b9081ebccde68.tar.bz2
gentoo-2-9924623967872297b2979d51507b9081ebccde68.zip
Version bump for security bugs 389427 and 395715. Removing unnneeded and vulnerable versions.
(Portage version: 2.2.0_alpha82/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/phpmyadmin/phpmyadmin-3.4.9.ebuild')
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-3.4.9.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/phpmyadmin-3.4.9.ebuild b/dev-db/phpmyadmin/phpmyadmin-3.4.9.ebuild
new file mode 100644
index 000000000000..6be5c923d910
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-3.4.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.4.9.ebuild,v 1.1 2011/12/23 21:39:50 a3li Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ <dev-lang/php-5.3[spl,pcre]
+ >=dev-lang/php-5.3
+ )
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog || die
+ rm -f LICENSE CREDITS INSTALL README* RELEASE-DATE-${MY_PV} TODO
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}