summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-04-20 15:57:36 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-04-20 15:57:36 +0000
commitd7eeb7c0551910590d32559127c149cb8dcca319 (patch)
tree0a7734560fcad09b3529ceb13183fb2fe6374180 /dev-db/phpmyadmin
parentFixing typo and closing bug #130596. (diff)
downloadgentoo-2-d7eeb7c0551910590d32559127c149cb8dcca319.tar.gz
gentoo-2-d7eeb7c0551910590d32559127c149cb8dcca319.tar.bz2
gentoo-2-d7eeb7c0551910590d32559127c149cb8dcca319.zip
Version bump (#129850); fixed postinstall instructions (#129590).
(Portage version: 2.1_pre9-r1)
Diffstat (limited to 'dev-db/phpmyadmin')
-rw-r--r--dev-db/phpmyadmin/ChangeLog9
-rw-r--r--dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.0.33
-rw-r--r--dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt2
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.8.0.3.ebuild81
4 files changed, 93 insertions, 2 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index c26ded17ba8e..e76b1606ee49 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.168 2006/04/08 20:46:43 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.169 2006/04/20 15:57:35 rl03 Exp $
+
+*phpmyadmin-2.8.0.3 (20 Apr 2006)
+
+ 20 Apr 2006; Renat Lumpau <rl03@gentoo.org>
+ files/postinstall-en-2.8.0.txt, -phpmyadmin-2.7.0_p2.ebuild,
+ +phpmyadmin-2.8.0.3.ebuild:
+ Version bump (#129850); fixed postinstall instructions (#129590).
08 Apr 2006; Mark Loeser <halcy0n@gentoo.org> phpmyadmin-2.8.0.2.ebuild:
Stable on x86; bug #129037
diff --git a/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.0.3 b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.0.3
new file mode 100644
index 000000000000..8e2beb966d15
--- /dev/null
+++ b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.0.3
@@ -0,0 +1,3 @@
+MD5 87ee2e17c9381e969c8f740242220e29 phpMyAdmin-2.8.0.3.tar.bz2 2011518
+RMD160 d40d236c4041c16a1d06e1c158f14707938ab16c phpMyAdmin-2.8.0.3.tar.bz2 2011518
+SHA256 89a15217b9b090ec01e1a4b90c90b2df2ac6b6e192c64385c816d33cc7efaff0 phpMyAdmin-2.8.0.3.tar.bz2 2011518
diff --git a/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt b/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt
index 980b3a92eee3..b5be9e7a97e9 100644
--- a/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt
+++ b/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt
@@ -9,7 +9,7 @@
Alternatively, use the default config file in libraries/config.default.php:
- cp ${MY_INSTALLDIR}/libraries/config.default.php ${MY_INSTALLDIR}/libraries/config.inc.php
+ cp ${MY_INSTALLDIR}/libraries/config.default.php ${MY_INSTALLDIR}/config.inc.php
2. Be sure that the libraries/ directory is not visible. You can use the
provided .htaccess file.
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.8.0.3.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.8.0.3.ebuild
new file mode 100644
index 000000000000..0d0211727a25
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.8.0.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.8.0.3.ebuild,v 1.1 2006/04/20 15:57:35 rl03 Exp $
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P=phpMyAdmin-${MY_PV}
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-db/mysql-3.23.32 <dev-db/mysql-5.1
+ sys-apps/findutils"
+S=${WORKDIR}/${MY_P}
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use pcre session
+ # see bug #124954
+ if ! built_with_use -o =${PHP_PKG} mysql mysqli ; then
+ eerror "${PHP_PKG} needs to be re-installed with one of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "mysql or mysqli if using dev-lang/php-5"
+ eerror "mysql if using dev-lang/php-4"
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/config.default.php-2.8.0.patch
+
+ # Remove .cvs* files and CVS directories
+ find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+}
+
+src_compile() {
+ einfo "Setting random user/password details for the controluser"
+
+ local pmapass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
+ sed -e "s/@pmapass@/${pmapass}/g" -i libraries/config.default.php
+ sed -e "s/@pmapass@/${pmapass}/g" \
+ ${FILESDIR}/mysql-setup.sql.in-2.5.6 > ${T}/mysql-setup.sql
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog"
+
+ # install the SQL scripts available to us
+ #
+ # unfortunately, we do not have scripts to upgrade from older versions
+ # these are things we need to add at a later date
+
+ webapp_sqlscript mysql ${T}/mysql-setup.sql
+
+ dodoc ${docs}
+ dohtml Documentation.html
+
+ # Copy the app's main files
+
+ einfo "Installing main files"
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/libraries/config.default.php
+ webapp_serverowned ${MY_HTDOCSDIR}/libraries/config.default.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-2.8.0.txt
+ webapp_hook_script ${FILESDIR}/reconfig-2.8
+ webapp_src_install
+ # bug #88831, make sure the create script is world-readable.
+ fperms 0600 ${MY_SQLSCRIPTSDIR}/mysql/${PVR}_create.sql
+}