summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-07-26 15:13:36 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-07-26 15:13:36 +0000
commit0367b81e51f274d0e68216b8e0df13ccc4efc6cd (patch)
treefc4aef445c109c58352bf0867e93334f81df8218 /dev-db/postgresql
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-0367b81e51f274d0e68216b8e0df13ccc4efc6cd.tar.gz
gentoo-2-0367b81e51f274d0e68216b8e0df13ccc4efc6cd.tar.bz2
gentoo-2-0367b81e51f274d0e68216b8e0df13ccc4efc6cd.zip
Fixed SHMMAX_MIN to calculate from MAX_CONNECTIONS.
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/ChangeLog5
-rw-r--r--dev-db/postgresql/postgresql-7.4.3-r1.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 4e116c35ac3d..c5d8c205445c 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.112 2004/07/21 19:11:10 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.113 2004/07/26 15:13:36 matsuu Exp $
+
+ 27 Jul 2004; MATSUU Takuto <matsuu@gentoo.org> postgresql-7.4.3-r1.ebuild:
+ Fixed SHMMAX_MIN to calculate from MAX_CONNECTIONS.
21 Jul 2004; Masatomo Nakano <nakano@gentoo.org> postgresql-7.3.6-r2.ebuild,
postgresql-7.4.3-r1.ebuild:
diff --git a/dev-db/postgresql/postgresql-7.4.3-r1.ebuild b/dev-db/postgresql/postgresql-7.4.3-r1.ebuild
index c3143d9f25fe..08b5c0e640a1 100644
--- a/dev-db/postgresql/postgresql-7.4.3-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.3-r1.ebuild,v 1.2 2004/07/21 19:11:10 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.3-r1.ebuild,v 1.3 2004/07/26 15:13:36 matsuu Exp $
inherit eutils gnuconfig flag-o-matic
@@ -258,7 +258,7 @@ pkg_config() {
local SEMMNI=`sysctl -n kernel.sem | cut -f4`
local SEMMNI_MIN=`expr \( ${MAX_CONNECTIONS} + 15 \) / 16`
local SHMMAX=`sysctl -n kernel.shmmax`
- local SHMMAX_MIN=134217728 # 128M
+ local SHMMAX_MIN=`expr 250000 + 30600 \* ${MAX_CONNECTIONS}`
if [ ${SEMMNI} -lt ${SEMMNI_MIN} ]; then
eerror "The current value of SEMMNI is too low"