summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-08-04 14:36:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-08-04 14:36:38 +0000
commit57b11b4c4d58fbfcdbd94f79036fa1f2309bcd63 (patch)
treeee6b258df5539db37a4cef362d589d8a9d419b1e /dev-db/postgresql
parentStable on sparc wrt #142610 (diff)
downloadgentoo-2-57b11b4c4d58fbfcdbd94f79036fa1f2309bcd63.tar.gz
gentoo-2-57b11b4c4d58fbfcdbd94f79036fa1f2309bcd63.tar.bz2
gentoo-2-57b11b4c4d58fbfcdbd94f79036fa1f2309bcd63.zip
USE flag split tcltk-> tcl & tk per bug #17808
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/ChangeLog7
-rw-r--r--dev-db/postgresql/postgresql-7.3.11.ebuild11
-rw-r--r--dev-db/postgresql/postgresql-7.3.15-r1.ebuild11
-rw-r--r--dev-db/postgresql/postgresql-7.4.13.ebuild11
-rw-r--r--dev-db/postgresql/postgresql-8.0.8.ebuild11
-rw-r--r--dev-db/postgresql/postgresql-8.1.4.ebuild13
6 files changed, 37 insertions, 27 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index f611d2fbfc93..12a009b8f0d9 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.285 2006/07/31 23:30:07 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.286 2006/08/04 14:36:38 cardoe Exp $
+
+ 04 Aug 2006; <dougg@gentoo.org> postgresql-7.3.11.ebuild,
+ postgresql-7.3.15-r1.ebuild, postgresql-7.4.13.ebuild,
+ postgresql-8.0.8.ebuild, postgresql-8.1.4.ebuild:
+ USE flag split tcltk-> tcl & tk per bug #17808
31 Jul 2006; Luca Longinotti <chtekk@gentoo.org>
-files/postgresql-7.3.15-cubeparse.patch,
diff --git a/dev-db/postgresql/postgresql-7.3.11.ebuild b/dev-db/postgresql/postgresql-7.3.11.ebuild
index 1088b7e526d4..2698227552dc 100644
--- a/dev-db/postgresql/postgresql-7.3.11.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.11.ebuild,v 1.11 2006/07/31 23:30:07 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.11.ebuild,v 1.12 2006/08/04 14:36:38 cardoe Exp $
inherit eutils gnuconfig flag-o-matic java-pkg
@@ -14,7 +14,7 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc s390 sh sparc x86"
-IUSE="doc java libg++ nls pam perl python readline ssl tcltk zlib threads selinux"
+IUSE="doc java libg++ nls pam perl python readline ssl tcl tk zlib threads selinux"
DEPEND="virtual/libc
=dev-db/libpq-7.3.11*
@@ -22,7 +22,8 @@ DEPEND="virtual/libc
>=sys-libs/ncurses-5.2
zlib? ( >=sys-libs/zlib-1.1.3 )
readline? ( >=sys-libs/readline-4.1 )
- tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ tcl? ( >=dev-lang/tcl-8 )
+ tk? ( >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
java? ( >=virtual/jdk-1.3 >=dev-java/ant-1.3
@@ -34,7 +35,7 @@ DEPEND="virtual/libc
RDEPEND="virtual/libc
=dev-db/libpq-7.3.11*
zlib? ( >=sys-libs/zlib-1.1.3 )
- tcltk? ( >=dev-lang/tcl-8 )
+ tcl? ( >=dev-lang/tcl-8 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 )
java? ( >=virtual/jdk-1.3 )
@@ -86,7 +87,7 @@ src_compile() {
fi
local myconf
- use tcltk && myconf="--with-tcl"
+ use tcl && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
use java && myconf="$myconf --with-java"
diff --git a/dev-db/postgresql/postgresql-7.3.15-r1.ebuild b/dev-db/postgresql/postgresql-7.3.15-r1.ebuild
index 441ae0fa6614..6473cdcbb4b5 100644
--- a/dev-db/postgresql/postgresql-7.3.15-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.15-r1.ebuild,v 1.4 2006/07/31 23:30:08 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.15-r1.ebuild,v 1.5 2006/08/04 14:36:38 cardoe Exp $
inherit eutils gnuconfig flag-o-matic java-pkg multilib
@@ -14,7 +14,7 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 mips ppc ~s390 ~sh ~sparc ~x86"
-IUSE="doc java libg++ nls pam perl python readline ssl tcltk zlib threads selinux"
+IUSE="doc java libg++ nls pam perl python readline ssl tcl tk zlib threads selinux"
DEPEND="virtual/libc
=dev-db/libpq-7.3.15*
@@ -22,7 +22,8 @@ DEPEND="virtual/libc
>=sys-libs/ncurses-5.2
zlib? ( >=sys-libs/zlib-1.1.3 )
readline? ( >=sys-libs/readline-4.1 )
- tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ tcl? ( >=dev-lang/tcl-8 )
+ tk? ( >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
java? ( >=virtual/jdk-1.3 >=dev-java/ant-1.3
@@ -34,7 +35,7 @@ DEPEND="virtual/libc
RDEPEND="virtual/libc
=dev-db/libpq-7.3.15*
zlib? ( >=sys-libs/zlib-1.1.3 )
- tcltk? ( >=dev-lang/tcl-8 )
+ tcl? ( >=dev-lang/tcl-8 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 )
java? ( >=virtual/jdk-1.3 )
@@ -86,7 +87,7 @@ src_compile() {
fi
local myconf
- use tcltk && myconf="--with-tcl"
+ use tcl && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
use java && myconf="$myconf --with-java"
diff --git a/dev-db/postgresql/postgresql-7.4.13.ebuild b/dev-db/postgresql/postgresql-7.4.13.ebuild
index 4acb5307cf6b..162efc4dbcea 100644
--- a/dev-db/postgresql/postgresql-7.4.13.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.13.ebuild,v 1.11 2006/07/30 22:30:54 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.13.ebuild,v 1.12 2006/08/04 14:36:38 cardoe Exp $
inherit eutils gnuconfig flag-o-matic java-pkg multilib toolchain-funcs
@@ -15,7 +15,7 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="ssl nls java python tcltk perl libg++ pam readline zlib doc pg-hier pg-vacuumdelay pg-intdatetime threads xml selinux"
+IUSE="ssl nls java python tcl tk perl libg++ pam readline zlib doc pg-hier pg-vacuumdelay pg-intdatetime threads xml selinux"
DEPEND="virtual/libc
=dev-db/libpq-7.4.13*
@@ -24,7 +24,8 @@ DEPEND="virtual/libc
>=sys-devel/bison-1.875
zlib? ( >=sys-libs/zlib-1.1.3 )
readline? ( >=sys-libs/readline-4.1 )
- tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ tcl? ( >=dev-lang/tcl-8 )
+ tk? ( >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
java? ( >=virtual/jdk-1.3 >=dev-java/ant-1.3
@@ -37,7 +38,7 @@ DEPEND="virtual/libc
RDEPEND="virtual/libc
=dev-db/libpq-7.4.13*
zlib? ( >=sys-libs/zlib-1.1.3 )
- tcltk? ( >=dev-lang/tcl-8 )
+ tcl? ( >=dev-lang/tcl-8 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 )
java? ( >=virtual/jdk-1.3 )
@@ -103,7 +104,7 @@ src_compile() {
fi
local myconf
- use tcltk && myconf="--with-tcl"
+ use tcl && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
use java && myconf="$myconf --with-java"
diff --git a/dev-db/postgresql/postgresql-8.0.8.ebuild b/dev-db/postgresql/postgresql-8.0.8.ebuild
index 2f021462111d..00a5abc87c37 100644
--- a/dev-db/postgresql/postgresql-8.0.8.ebuild
+++ b/dev-db/postgresql/postgresql-8.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.8.ebuild,v 1.11 2006/07/30 22:30:54 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.8.ebuild,v 1.12 2006/08/04 14:36:38 cardoe Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -17,7 +17,7 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${MY_PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="ssl nls python tcltk perl libg++ pam readline xml zlib doc selinux kerberos pg-intdatetime pg-hier"
+IUSE="ssl nls python tcl tk perl libg++ pam readline xml zlib doc selinux kerberos pg-intdatetime pg-hier"
S=${WORKDIR}/${MY_P}
DEPEND="virtual/libc
@@ -27,7 +27,8 @@ DEPEND="virtual/libc
>=sys-devel/bison-1.875
zlib? ( >=sys-libs/zlib-1.1.3 )
readline? ( >=sys-libs/readline-4.1 )
- tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ tcl? ( >=dev-lang/tcl-8 )
+ tk? ( >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
@@ -37,7 +38,7 @@ DEPEND="virtual/libc
RDEPEND="virtual/libc
=dev-db/libpq-8.0.8*
zlib? ( >=sys-libs/zlib-1.1.3 )
- tcltk? ( >=dev-lang/tcl-8 )
+ tcl? ( >=dev-lang/tcl-8 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 )
selinux? ( sec-policy/selinux-postgresql )
@@ -79,7 +80,7 @@ src_compile() {
filter-flags -ffast-math -feliminate-dwarf2-dups
local myconf
- use tcltk && myconf="--with-tcl"
+ use tcl && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
use ssl && myconf="$myconf --with-openssl"
diff --git a/dev-db/postgresql/postgresql-8.1.4.ebuild b/dev-db/postgresql/postgresql-8.1.4.ebuild
index 913afa5a336c..b10480d61ea5 100644
--- a/dev-db/postgresql/postgresql-8.1.4.ebuild
+++ b/dev-db/postgresql/postgresql-8.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.1.4.ebuild,v 1.3 2006/07/30 22:30:54 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.1.4.ebuild,v 1.4 2006/08/04 14:36:38 cardoe Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -15,8 +15,8 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-#IUSE="ssl nls python tcltk perl libg++ pam readline xml zlib doc selinux kerberos pg-intdatetime pg-hier"
-IUSE="ssl nls python tcltk perl libg++ pam readline xml zlib doc selinux kerberos pg-intdatetime threads"
+#IUSE="ssl nls python tcl tk perl libg++ pam readline xml zlib doc selinux kerberos pg-intdatetime pg-hier"
+IUSE="ssl nls python tcl tk perl libg++ pam readline xml zlib doc selinux kerberos pg-intdatetime threads"
DEPEND="virtual/libc
=dev-db/libpq-8.1.4*
@@ -25,7 +25,8 @@ DEPEND="virtual/libc
>=sys-devel/bison-1.875
zlib? ( >=sys-libs/zlib-1.1.3 )
readline? ( >=sys-libs/readline-4.1 )
- tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ tcl? ( >=dev-lang/tcl-8 )
+ tk? ( >=dev-lang/tk-8.3.3-r1 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
@@ -35,7 +36,7 @@ DEPEND="virtual/libc
RDEPEND="virtual/libc
=dev-db/libpq-8.1.4*
zlib? ( >=sys-libs/zlib-1.1.3 )
- tcltk? ( >=dev-lang/tcl-8 )
+ tcl? ( >=dev-lang/tcl-8 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 )
selinux? ( sec-policy/selinux-postgresql )
@@ -75,7 +76,7 @@ src_compile() {
filter-flags -ffast-math -feliminate-dwarf2-dups
local myconf
- use tcltk && myconf="--with-tcl"
+ use tcl && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
use ssl && myconf="$myconf --with-openssl"