summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-01-24 12:09:13 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-01-24 12:09:13 +0000
commit2716784287789baaaaca336e9db3089de2f45a61 (patch)
tree0492c9148a697900e08534f069db0d50e68a7d13 /dev-db/redis
parentEmit message about split out easy-rsa. (diff)
downloadgentoo-2-2716784287789baaaaca336e9db3089de2f45a61.tar.gz
gentoo-2-2716784287789baaaaca336e9db3089de2f45a61.tar.bz2
gentoo-2-2716784287789baaaaca336e9db3089de2f45a61.zip
Version bump redis to 2.6.9 (bug 453606).
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-db/redis')
-rw-r--r--dev-db/redis/ChangeLog8
-rw-r--r--dev-db/redis/files/redis-2.6.9-tclsh86.patch57
-rw-r--r--dev-db/redis/redis-2.6.9.ebuild101
3 files changed, 165 insertions, 1 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index 693f18697e8a..58bb2d7ef62f 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.56 2013/01/12 14:51:30 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.57 2013/01/24 12:09:13 djc Exp $
+
+*redis-2.6.9 (24 Jan 2013)
+
+ 24 Jan 2013; Dirkjan Ochtman <djc@gentoo.org> +redis-2.6.9.ebuild,
+ +files/redis-2.6.9-tclsh86.patch:
+ Version bump to 2.6.9 (bug 453606).
*redis-2.6.8 (12 Jan 2013)
diff --git a/dev-db/redis/files/redis-2.6.9-tclsh86.patch b/dev-db/redis/files/redis-2.6.9-tclsh86.patch
new file mode 100644
index 000000000000..00d81dfafcc7
--- /dev/null
+++ b/dev-db/redis/files/redis-2.6.9-tclsh86.patch
@@ -0,0 +1,57 @@
+diff --git a/runtest b/runtest
+index 0eb384c..fadc283 100755
+--- a/runtest
++++ b/runtest
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-TCL=tclsh8.5
++TCL=tclsh
+ which $TCL
+ if [ "$?" != "0" ]
+ then
+diff --git a/tests/integration/replication-4.tcl b/tests/integration/replication-4.tcl
+index 69fcab3..58a70fa 100644
+--- a/tests/integration/replication-4.tcl
++++ b/tests/integration/replication-4.tcl
+@@ -1,5 +1,5 @@
+ proc start_bg_complex_data {host port db ops} {
+- exec tclsh8.5 tests/helpers/bg_complex_data.tcl $host $port $db $ops &
++ exec tclsh tests/helpers/bg_complex_data.tcl $host $port $db $ops &
+ }
+
+ proc stop_bg_complex_data {handle} {
+diff --git a/tests/integration/replication.tcl b/tests/integration/replication.tcl
+index da94b08..30baf6a 100644
+--- a/tests/integration/replication.tcl
++++ b/tests/integration/replication.tcl
+@@ -78,7 +78,7 @@ start_server {tags {"repl"}} {
+ }
+
+ proc start_write_load {host port seconds} {
+- exec tclsh8.5 tests/helpers/gen_write_load.tcl $host $port $seconds &
++ exec tclsh tests/helpers/gen_write_load.tcl $host $port $seconds &
+ }
+
+ proc stop_write_load {handle} {
+diff --git a/tests/test_helper.tcl b/tests/test_helper.tcl
+index b2e58b4..253e955 100644
+--- a/tests/test_helper.tcl
++++ b/tests/test_helper.tcl
+@@ -2,6 +2,8 @@
+ # This softare is released under the BSD License. See the COPYING file for
+ # more information.
+
++package require Tcl 8.5
++
+ set tcl_precision 17
+ source tests/support/redis.tcl
+ source tests/support/server.tcl
+@@ -189,7 +191,7 @@ proc test_server_main {} {
+ set start_port [expr {$::port+100}]
+ for {set j 0} {$j < $::numclients} {incr j} {
+ set start_port [find_available_port $start_port]
+- set p [exec tclsh8.5 [info script] {*}$::argv \
++ set p [exec tclsh [info script] {*}$::argv \
+ --client $port --port $start_port &]
+ lappend ::clients_pids $p
+ incr start_port 10 \ No newline at end of file
diff --git a/dev-db/redis/redis-2.6.9.ebuild b/dev-db/redis/redis-2.6.9.ebuild
new file mode 100644
index 000000000000..6c5f7ec291b9
--- /dev/null
+++ b/dev-db/redis/redis-2.6.9.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.6.9.ebuild,v 1.1 2013/01/24 12:09:13 djc Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic user
+
+DESCRIPTION="A persistent caching system, key-value and data structures database."
+HOMEPAGE="http://redis.io/"
+SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
+IUSE="+jemalloc tcmalloc test"
+SLOT="0"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND=">=sys-devel/autoconf-2.63
+ test? ( dev-lang/tcl )
+ ${RDEPEND}"
+REQUIRED_USE="tcmalloc? ( !jemalloc )
+ jemalloc? ( !tcmalloc )"
+
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+pkg_setup() {
+ enewgroup redis 75
+ enewuser redis 75 -1 /var/lib/redis redis
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.6.7"-{shared,config}.patch
+ epatch "${FILESDIR}/${P}"-tclsh86.patch
+ # now we will rewrite present Makefiles
+ local makefiles=""
+ for MKF in $(find -name 'Makefile' | cut -b 3-); do
+ mv "${MKF}" "${MKF}.in"
+ sed -i -e 's:$(CC):@CC@:g' \
+ -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
+ -e 's: $(DEBUG)::g' \
+ -e 's:$(OBJARCH)::g' \
+ -e 's:ARCH:TARCH:g' \
+ -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
+ "${MKF}.in" \
+ || die "Sed failed for ${MKF}"
+ makefiles+=" ${MKF}"
+ done
+ # autodetection of compiler and settings; generates the modified Makefiles
+ cp "${FILESDIR}"/configure.ac-2.2 configure.ac
+ sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
+ configure.ac || die "Sed failed for configure.ac"
+ eautoconf
+}
+
+src_configure() {
+ econf
+
+ # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
+ # also, don't define ANSI/c99 for lua twice
+ sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
+}
+
+src_compile() {
+ local myconf=""
+
+ if use tcmalloc ; then
+ myconf="${myconf} USE_TCMALLOC=yes"
+ elif use jemalloc ; then
+ myconf="${myconf} JEMALLOC_SHARED=yes"
+ else
+ myconf="${myconf} MALLOC=yes"
+ fi
+
+ emake ${myconf}
+}
+
+src_install() {
+ insinto /etc/
+ doins redis.conf sentinel.conf
+ use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
+ fperms 0644 /etc/{redis,sentinel}.conf
+
+ newconfd "${FILESDIR}/redis.confd" redis
+ newinitd "${FILESDIR}/redis.initd" redis
+
+ nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
+
+ dobin src/redis-cli
+ dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
+ fperms 0750 /usr/sbin/redis-benchmark
+ dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
+
+ if use prefix; then
+ diropts -m0750
+ else
+ diropts -m0750 -o redis -g redis
+ fi
+ keepdir /var/{log,lib}/redis
+}