summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-14 17:37:58 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-14 17:37:58 +0000
commit339ce7caba6a53e8236a152cca591c2194b324ec (patch)
treecedef05da56af3f4c3bc49f938883cd192502f10 /dev-db
parentFix the test broken RESTRICT atom that Cardoe added. The tcl use flag must be... (diff)
downloadgentoo-2-339ce7caba6a53e8236a152cca591c2194b324ec.tar.gz
gentoo-2-339ce7caba6a53e8236a152cca591c2194b324ec.tar.bz2
gentoo-2-339ce7caba6a53e8236a152cca591c2194b324ec.zip
Fix the rest of the ebuilds wrt tcl and test suite.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r4.ebuild17
-rw-r--r--dev-db/sqlite/sqlite-3.3.12.ebuild17
-rw-r--r--dev-db/sqlite/sqlite-3.3.5-r1.ebuild17
4 files changed, 41 insertions, 16 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 450c147e0af5..c5ce0569afba 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.150 2007/06/14 17:31:45 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.151 2007/06/14 17:37:58 betelgeuse Exp $
+
+ 14 Jun 2007; Petteri Räty <betelgeuse@gentoo.org>
+ sqlite-2.8.16-r4.ebuild, sqlite-3.3.5-r1.ebuild, sqlite-3.3.12.ebuild:
+ Fix the rest of the ebuilds wrt tcl and test suite.
14 Jun 2007; Petteri Räty <betelgeuse@gentoo.org> sqlite-3.3.17.ebuild:
Fix the test broken RESTRICT atom that Cardoe added. The tcl use flag must
diff --git a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
index a000f0a60b65..51b8f823d493 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.18 2007/05/23 01:14:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.19 2007/06/14 17:37:58 betelgeuse Exp $
inherit eutils alternatives toolchain-funcs
@@ -21,13 +21,20 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
-RESTRICT="tcl? ( test )"
+RESTRICT="!tcl? ( test )"
src_unpack() {
# test
- if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl; then
+ ewarn "You must enable the tcl use flag if you want to run the test"
+ ewarn "suite."
+ eerror "Testsuite will not be run."
+ fi
fi
unpack ${A}
diff --git a/dev-db/sqlite/sqlite-3.3.12.ebuild b/dev-db/sqlite/sqlite-3.3.12.ebuild
index 5039043f22f9..48c4c13aa76e 100644
--- a/dev-db/sqlite/sqlite-3.3.12.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.12 2007/06/14 09:43:43 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.13 2007/06/14 17:37:58 betelgeuse Exp $
inherit eutils alternatives libtool
@@ -21,13 +21,20 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
-RESTRICT="tcl? ( test )"
+RESTRICT="!tcl? ( test )"
src_unpack() {
# test
- if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl; then
+ ewarn "You must enable the tcl use flag if you want to run the test"
+ ewarn "suite."
+ eerror "Testsuite will not be run."
+ fi
fi
unpack ${A}
diff --git a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
index 21d2cb42c015..298ccba1c1eb 100644
--- a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.18 2007/05/23 01:14:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.19 2007/06/14 17:37:58 betelgeuse Exp $
inherit eutils alternatives
@@ -21,13 +21,20 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
-RESTRICT="tcl? ( test )"
+RESTRICT="!tcl? ( test )"
src_unpack() {
# test
- if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl; then
+ ewarn "You must enable the tcl use flag if you want to run the test"
+ ewarn "suite."
+ eerror "Testsuite will not be run."
+ fi
fi
unpack ${A}