summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-05-09 21:38:07 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-05-09 21:38:07 +0000
commit59ca956dddb03ab34a840d370eb67fad1ccbca26 (patch)
treedd897cc235566230f76fb6a79350f1ea396a3253 /dev-db
parentVersion bump (diff)
downloadgentoo-2-59ca956dddb03ab34a840d370eb67fad1ccbca26.tar.gz
gentoo-2-59ca956dddb03ab34a840d370eb67fad1ccbca26.tar.bz2
gentoo-2-59ca956dddb03ab34a840d370eb67fad1ccbca26.zip
Added missing include files.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libpq/ChangeLog6
-rw-r--r--dev-db/libpq/libpq-3.2.ebuild26
-rw-r--r--dev-db/libpq/libpq-4.0.ebuild26
3 files changed, 41 insertions, 17 deletions
diff --git a/dev-db/libpq/ChangeLog b/dev-db/libpq/ChangeLog
index a9412a9eee5f..bc2d52ce214a 100644
--- a/dev-db/libpq/ChangeLog
+++ b/dev-db/libpq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/libpq
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.2 2005/05/08 23:00:24 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.3 2005/05/09 21:38:07 nakano Exp $
+
+ 09 May 2005; Masatomo Nakano <nakano@gentoo.org> libpq-3.2.ebuild,
+ libpq-4.0.ebuild:
+ Added missing include files.
08 May 2005; Masatomo Nakano <nakano@gentoo.org> libpq-3.2.ebuild,
libpq-4.0.ebuild:
diff --git a/dev-db/libpq/libpq-3.2.ebuild b/dev-db/libpq/libpq-3.2.ebuild
index 78dac6a05175..a9d4b85378ed 100644
--- a/dev-db/libpq/libpq-3.2.ebuild
+++ b/dev-db/libpq/libpq-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-3.2.ebuild,v 1.2 2005/05/08 23:00:24 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-3.2.ebuild,v 1.3 2005/05/09 21:38:07 nakano Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -74,15 +74,25 @@ src_install() {
cd ${S}/src/interfaces/libpq
make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}/src/include
+ make DESTDIR=${D} install || die
+
cd ${S}
dodoc README HISTORY COPYRIGHT INSTALL
- cp src/include/postgres_ext.h ${D}/usr/include/postgresql/libpq-${SLOT}
-
dosym /usr/lib/libpq-${SLOT}.a /usr/lib/libpq.a
- dodir /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/libpq-fe.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/postgres_ext.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/libpq-int.h /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/pqexpbuffer.h /usr/include/postgresql/internal/
+
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/*.h ${D}/usr/include/
+
+ dodir /usr/include/libpq
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/libpq/*.h ${D}/usr/include/libpq
+
+ cd ${D}/usr/include/postgresql/libpq-${SLOT}
+ for f in $(find . -name '*.h' -print) ; do
+ destdir=$(dirname $f)
+ if [ ! -d "${D}/usr/include/postgresql/${destdir}" ]; then
+ mkdir -p ${D}/usr/include/postgresql/${destdir}
+ fi
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/${f} ${D}/usr/include/postgresql/${destdir}/
+ done
}
diff --git a/dev-db/libpq/libpq-4.0.ebuild b/dev-db/libpq/libpq-4.0.ebuild
index edb84dc6ea2a..c43c6db6a8b4 100644
--- a/dev-db/libpq/libpq-4.0.ebuild
+++ b/dev-db/libpq/libpq-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-4.0.ebuild,v 1.2 2005/05/08 23:00:24 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-4.0.ebuild,v 1.3 2005/05/09 21:38:07 nakano Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -74,15 +74,25 @@ src_install() {
cd ${S}/src/interfaces/libpq
make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}/src/include
+ make DESTDIR=${D} install || die
+
cd ${S}
dodoc README HISTORY COPYRIGHT INSTALL
- cp src/include/postgres_ext.h ${D}/usr/include/postgresql/libpq-${SLOT}
-
dosym /usr/lib/libpq-${SLOT}.a /usr/lib/libpq.a
- dodir /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/libpq-fe.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/postgres_ext.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/libpq-int.h /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/pqexpbuffer.h /usr/include/postgresql/internal/
+
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/*.h ${D}/usr/include/
+
+ dodir /usr/include/libpq
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/libpq/*.h ${D}/usr/include/libpq
+
+ cd ${D}/usr/include/postgresql/libpq-${SLOT}
+ for f in $(find . -name '*.h' -print) ; do
+ destdir=$(dirname $f)
+ if [ ! -d "${D}/usr/include/postgresql/${destdir}" ]; then
+ mkdir -p ${D}/usr/include/postgresql/${destdir}
+ fi
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/${f} ${D}/usr/include/postgresql/${destdir}/
+ done
}