summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-12 20:47:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-12 20:47:55 +0000
commit9db879beef5f0c5fd8b9373104b3d8d8c15376f9 (patch)
treeb0281a9f2a2140c013b03aca1ae3b0624ae87efc /dev-db
parentamd64 stable wrt #296432 (diff)
downloadgentoo-2-9db879beef5f0c5fd8b9373104b3d8d8c15376f9.tar.gz
gentoo-2-9db879beef5f0c5fd8b9373104b3d8d8c15376f9.tar.bz2
gentoo-2-9db879beef5f0c5fd8b9373104b3d8d8c15376f9.zip
Fix building and dependencies (bug #296245).
(Portage version: 15055-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/sqlite-3.6.21.ebuild45
2 files changed, 17 insertions, 34 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 9f6424949864..e7154694bdb7 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.297 2009/12/08 11:30:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.298 2009/12/12 20:47:55 arfrever Exp $
+
+ 12 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ sqlite-3.6.21.ebuild:
+ Fix building and dependencies (bug #296245).
*sqlite-3.6.21 (08 Dec 2009)
diff --git a/dev-db/sqlite/sqlite-3.6.21.ebuild b/dev-db/sqlite/sqlite-3.6.21.ebuild
index f20304fc0ad6..0729f8ce61f6 100644
--- a/dev-db/sqlite/sqlite-3.6.21.ebuild
+++ b/dev-db/sqlite/sqlite-3.6.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.21.ebuild,v 1.1 2009/12/08 11:30:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.21.ebuild,v 1.2 2009/12/12 20:47:55 arfrever Exp $
EAPI="2"
@@ -11,41 +11,25 @@ HOMEPAGE="http://www.sqlite.org/"
DOC_BASE="$(get_version_component_range 1-3)"
DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
SRC_URI="http://www.sqlite.org/${P}.tar.gz
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )
- !tcl? ( mirror://gentoo/sqlite3.h-${PV}.bz2 )"
+ doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
LICENSE="as-is"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="debug doc fts3 icu +readline soundex tcl +threadsafe"
-RESTRICT="!tcl? ( test )"
RDEPEND="icu? ( dev-libs/icu )
readline? ( sys-libs/readline )
tcl? ( dev-lang/tcl )"
DEPEND="${RDEPEND}
+ dev-lang/tcl
doc? ( app-arch/unzip )"
-pkg_setup() {
- if ! use tcl; then
- ewarn "Installation of SQLite with \"tcl\" USE flag enabled provides more (TCL-unrelated) functionality."
-
- if use icu; then
- ewarn "Support for ICU is enabled only when \"tcl\" USE flag is enabled."
- fi
-
- ebeep 1
- fi
-}
-
src_prepare() {
if use icu; then
rm -f test/like.test
fi
- # Needed to compile without tcl installed but fails to compile when it is installed, bug #293405
- use fts3 && ! has_version dev-lang/tcl && epatch "${FILESDIR}/sqlite-3.6.20-fts3.patch"
-
epunt_cxx
}
@@ -54,21 +38,22 @@ src_configure() {
append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
# Support R-trees, bug #257646
- # Avoid "./.libs/libsqlite3.so: undefined reference to `sqlite3RtreeInit'" during non-amalgamation building.
- if use tcl; then
- append-cppflags -DSQLITE_ENABLE_RTREE
- fi
+ append-cppflags -DSQLITE_ENABLE_RTREE
- if use icu && use tcl; then
+ if use icu; then
append-cppflags -DSQLITE_ENABLE_ICU
sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
fi
# Support soundex, bug #143794
- use soundex && append-cppflags -DSQLITE_SOUNDEX
+ if use soundex; then
+ append-cppflags -DSQLITE_SOUNDEX
+ fi
- # http://bugs.gentoo.org/show_bug.cgi?id=207701
- use fts3 && append-cppflags -DSQLITE_ENABLE_FTS3=1
+ # Support FTS3, bug #207701
+ if use fts3; then
+ append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
+ fi
econf \
$(use_enable debug) \
@@ -79,7 +64,6 @@ src_configure() {
}
src_compile() {
- use tcl || cp "${WORKDIR}/sqlite3.h-${PV}" sqlite3.h
emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
}
@@ -92,11 +76,6 @@ src_test() {
ewarn "The userpriv feature must be enabled to run tests."
eerror "Testsuite will not be run."
fi
-
- if ! use tcl; then
- ewarn "You must enable the tcl USE flag if you want to run the testsuite."
- eerror "Testsuite will not be run."
- fi
}
src_install() {