summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-03-02 18:23:47 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-03-02 18:23:47 +0000
commita974ee411dab8b55f3a900b9e05395e2c52492be (patch)
tree25c19e20fdf005751123ccfd2d2dc0517cb9e9da /dev-db
parentstable on amd64. see #83686 (diff)
downloadgentoo-2-a974ee411dab8b55f3a900b9e05395e2c52492be.tar.gz
gentoo-2-a974ee411dab8b55f3a900b9e05395e2c52492be.tar.bz2
gentoo-2-a974ee411dab8b55f3a900b9e05395e2c52492be.zip
new version
(Portage version: 2.0.51.18)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/Manifest2
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.1.31
-rw-r--r--dev-db/sqlite/sqlite-3.1.3.ebuild62
4 files changed, 71 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 5bc9c2dec6a7..f728b5863c9d 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.65 2005/02/18 19:23:20 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.66 2005/03/02 18:23:47 arj Exp $
+*sqlite-3.1.3 (02 Mar 2005)
+
+ 02 Mar 2005; Anders Rune Jensen <arj@gentoo.org> +sqlite-3.1.3.ebuild:
+ New version.
+
19 Feb 2005; Anders Rune Jensen <arj@gentoo.org> sqlite-3.1.2.ebuild:
Fix #82438.
diff --git a/dev-db/sqlite/Manifest b/dev-db/sqlite/Manifest
index 6908c56a4345..4c05e967f568 100644
--- a/dev-db/sqlite/Manifest
+++ b/dev-db/sqlite/Manifest
@@ -3,6 +3,7 @@ MD5 cab8e8e0ca9deb3af02594db21a81787 sqlite-2.8.15.ebuild 974
MD5 fdbecebdb331496cd81f02ea4487e430 sqlite-2.8.13.ebuild 843
MD5 53101d0aba85e7f9f18c84aada8466cf sqlite-3.0.8.ebuild 1020
MD5 529fd03eceab183a8c3dea72741c7266 sqlite-3.0.6.ebuild 1046
+MD5 c0c61638e3f6d70263748a5db601414d sqlite-3.1.3.ebuild 1882
MD5 8cda692208b4f43344d30e5bfa2ee396 sqlite-2.8.16.ebuild 1402
MD5 4c0a171d9f592a2ad9b147fa6cc06c56 ChangeLog 8953
MD5 c0c61638e3f6d70263748a5db601414d sqlite-3.1.2.ebuild 1882
@@ -10,6 +11,7 @@ MD5 99bf2a671c91f7499255003439d5eac0 sqlite-2.8.14.ebuild 862
MD5 f29cd1d06dca071985256cb325d2b380 sqlite-3.0.7.ebuild 995
MD5 006d5e8c0eb41234ac90294b6fd93f2d sqlite-3.0.8-r1.ebuild 1817
MD5 c9c200833c7c14eb4d750bb00455199e files/digest-sqlite-2.8.14 65
+MD5 2a35fca391c8617c26b2934d02b8fcb5 files/digest-sqlite-3.1.3 65
MD5 c35f34620d18893001720951f8ea0c73 files/digest-sqlite-2.8.13 65
MD5 60fec205107aa53f0cf83d62c2300183 files/sqlite-2.8.16-multilib.patch 4038
MD5 e92b7000fca35af325e2ac65bce666e0 files/digest-sqlite-3.0.7 65
diff --git a/dev-db/sqlite/files/digest-sqlite-3.1.3 b/dev-db/sqlite/files/digest-sqlite-3.1.3
new file mode 100644
index 000000000000..7fe167777016
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-3.1.3
@@ -0,0 +1 @@
+MD5 032273f53d0508e21b1d50d82a34268d sqlite-3.1.3.tar.gz 1315439
diff --git a/dev-db/sqlite/sqlite-3.1.3.ebuild b/dev-db/sqlite/sqlite-3.1.3.ebuild
new file mode 100644
index 000000000000..f7b4cf1186f0
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.1.3.ebuild,v 1.1 2005/03/02 18:23:47 arj Exp $
+
+inherit eutils
+
+IUSE="nls nothreadsafe"
+
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+HOMEPAGE="http://www.sqlite.org"
+
+# Adding glibc as dependency for USE !nothreadsafe until someone can tell me
+# if all virtual/libc's provide POSIX threads (pthread.h)
+# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+DEPEND="virtual/libc
+ !nothreadsafe? ( sys-libs/glibc )
+ dev-lang/tcl"
+SLOT="3"
+LICENSE="as-is"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+src_compile() {
+ # sqlite includes a doc directory making it impossible to generate docs,
+ # which are very important to people adding support for sqlite3 to their
+ # programs.
+ rm -rf doc/
+
+ local myconf
+ myconf="--enable-incore-db --enable-tempdb-in-ram"
+ # Yes, this is ridiculous, but I'm not the maintainer for this ebuild,
+ # and yet it's broken w/o thread support, so this has to do for now
+ # - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+ if ! use nothreadsafe; then
+ myconf="${myconf} --enable-threadsafe"
+ else
+ myconf="${myconf} --disable-threadsafe"
+ fi
+ myconf="${myconf} `use_with nls utf8`"
+ myconf="--with-tcl=/usr/$(get_libdir)/"
+ econf ${myconf} || die
+ emake all || die # doc is not working yet in 3.1.2
+}
+
+# In case we ever want testing support; note: this needs more work, as
+# as it causes some sandbox issues.
+# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+#src_test() {
+# cd ${S}
+# emake fulltest || die "some test failed"
+#}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ dobin lemon
+ dodoc README VERSION
+ doman sqlite.1
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+}