summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-08-02 01:24:54 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-08-02 01:24:54 +0000
commitbc65ddaff540956c8ba58888150b955b04eae41d (patch)
tree00a68af63842e0c8b57d583f0dee0a4e9d59238d /dev-db
parentAnnouncing g-cpan-0.14.0. Any further bug fixes that arise will go into 0.14.1 (diff)
downloadgentoo-2-bc65ddaff540956c8ba58888150b955b04eae41d.tar.gz
gentoo-2-bc65ddaff540956c8ba58888150b955b04eae41d.tar.bz2
gentoo-2-bc65ddaff540956c8ba58888150b955b04eae41d.zip
Version bump, fix security bug #142429.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog7
-rw-r--r--dev-db/mysql/files/digest-mysql-4.1.216
-rw-r--r--dev-db/mysql/mysql-4.1.21.ebuild35
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index c705a058e98a..affb255b760c 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.349 2006/07/30 13:56:55 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.350 2006/08/02 01:24:54 chtekk Exp $
+
+*mysql-4.1.21 (02 Aug 2006)
+
+ 02 Aug 2006; Luca Longinotti <chtekk@gentoo.org> +mysql-4.1.21.ebuild:
+ Version bump, fix security bug #142429.
30 Jul 2006; Luca Longinotti <chtekk@gentoo.org> -mysql-4.1.14-r1.ebuild:
Remove old version.
diff --git a/dev-db/mysql/files/digest-mysql-4.1.21 b/dev-db/mysql/files/digest-mysql-4.1.21
new file mode 100644
index 000000000000..b42264249bfa
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-4.1.21
@@ -0,0 +1,6 @@
+MD5 d3e0127078981590095d331d4e745d73 mysql-4.1.21.tar.gz 17624947
+RMD160 a8e92bb3b1371cde3fd938482b34cb597403debf mysql-4.1.21.tar.gz 17624947
+SHA256 43a23ab44fdbd4893e1f5076a2f7fa1540afbaa617e772202099acd24af0e3c5 mysql-4.1.21.tar.gz 17624947
+MD5 d20b14adb19c091ce86287df8c896f69 mysql-patchset-4.1.21-r1.tar.bz2 3851
+RMD160 61ea4ef8d630f5e9fad1daa9e0d4204b2b6a94bf mysql-patchset-4.1.21-r1.tar.bz2 3851
+SHA256 68a161055ae75a5668bea4534586261638f3471c30ee52cd6e2f0b4f6835751e mysql-patchset-4.1.21-r1.tar.bz2 3851
diff --git a/dev-db/mysql/mysql-4.1.21.ebuild b/dev-db/mysql/mysql-4.1.21.ebuild
new file mode 100644
index 000000000000..a8cd8b441425
--- /dev/null
+++ b/dev-db/mysql/mysql-4.1.21.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.21.ebuild,v 1.1 2006/08/02 01:24:54 chtekk Exp $
+
+# Leave this empty
+MYSQL_VERSION_ID=""
+# Set the patchset revision to use, must be either empty or a decimal number
+MYSQL_PATCHSET_REV="1"
+
+inherit mysql
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+src_test() {
+ cd "${S}"
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! useq "minimal" ; then
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ cd mysql-test
+ sed -i -e "s|PORT=3306|PORT=3307|g" mysql-test-run
+ ./mysql-test-run
+ retstatus=$?
+
+ # Just to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus -eq 0 ]] || die "make test failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}