summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-07-28 19:28:30 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-07-28 19:28:30 +0000
commitc49352631f02fcce81d5f561e2b84c3d87a61c42 (patch)
treedb3a685f6a18c8d058e2ba4aa2cef4ea25dda797 /dev-db
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-c49352631f02fcce81d5f561e2b84c3d87a61c42.tar.gz
gentoo-2-c49352631f02fcce81d5f561e2b84c3d87a61c42.tar.bz2
gentoo-2-c49352631f02fcce81d5f561e2b84c3d87a61c42.zip
USE flag change. tcltk -> tcl per bug #17808
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r1.ebuild10
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r3.ebuild16
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r4.ebuild18
-rw-r--r--dev-db/sqlite/sqlite-3.3.4.ebuild14
-rw-r--r--dev-db/sqlite/sqlite-3.3.5-r1.ebuild14
-rw-r--r--dev-db/sqlite/sqlite-3.3.5.ebuild14
-rw-r--r--dev-db/sqlite/sqlite-3.3.6.ebuild14
8 files changed, 56 insertions, 51 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 3dd7beadbabb..e3b5b6691c12 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.119 2006/07/22 20:25:32 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.120 2006/07/28 19:28:30 cardoe Exp $
+
+ 28 Jul 2006; <dougg@gentoo.org> sqlite-2.8.16-r1.ebuild,
+ sqlite-2.8.16-r3.ebuild, sqlite-2.8.16-r4.ebuild, sqlite-3.3.4.ebuild,
+ sqlite-3.3.5.ebuild, sqlite-3.3.5-r1.ebuild, sqlite-3.3.6.ebuild:
+ USE flag change. tcltk -> tcl per bug #17808
22 Jul 2006; Tobias Scherbaum <dertobi123@gentoo.org>
sqlite-2.8.16-r4.ebuild, sqlite-3.3.5-r1.ebuild:
diff --git a/dev-db/sqlite/sqlite-2.8.16-r1.ebuild b/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
index 2ea337cf4850..4b4d3d8d9f0c 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r1.ebuild,v 1.12 2006/06/11 18:28:03 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r1.ebuild,v 1.13 2006/07/28 19:28:30 cardoe Exp $
inherit eutils toolchain-funcs
@@ -11,10 +11,10 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc-macos ppc64 sh sparc x86"
-IUSE="nls doc tcltk"
+IUSE="nls doc tcl"
DEPEND="doc? ( dev-lang/tcl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
src_unpack() {
unpack ${A}
@@ -53,7 +53,7 @@ src_compile() {
emake doc || die
fi
- if use tcltk; then
+ if use tcl; then
cp -P ${FILESDIR}/maketcllib.sh ${S}
chmod +x ./maketcllib.sh
./maketcllib.sh
@@ -74,7 +74,7 @@ src_install () {
dohtml doc/*.html doc/*.txt doc/*.png
fi
- if use tcltk; then
+ if use tcl; then
mkdir ${D}/usr/lib/tclsqlite${PV}
cp ${S}/tclsqlite.so ${D}/usr/lib/tclsqlite${PV}/
cp ${S}/pkgIndex.tcl ${D}/usr/lib/tclsqlite${PV}/
diff --git a/dev-db/sqlite/sqlite-2.8.16-r3.ebuild b/dev-db/sqlite/sqlite-2.8.16-r3.ebuild
index 4351ddd16d58..350d000a524c 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r3.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r3.ebuild,v 1.3 2006/05/06 20:46:32 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r3.ebuild,v 1.4 2006/07/28 19:28:30 cardoe Exp $
inherit eutils toolchain-funcs alternatives
@@ -12,10 +12,10 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
-IUSE="nls doc tcltk"
+IUSE="nls doc tcl"
DEPEND="doc? ( dev-lang/tcl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
@@ -27,8 +27,8 @@ src_unpack() {
ewarn "The userpriv feature must be enabled to run tests."
ewarn "The testsuite will be skipped."
fi
- if ! use tcltk; then
- ewarn "The tcltk useflag must be enabled to run tests."
+ if ! use tcl; then
+ ewarn "The tcl useflag must be enabled to run tests."
ewarn "The testsuite will be skipped."
fi
fi
@@ -61,7 +61,7 @@ src_compile() {
myconf="--enable-incore-db --enable-tempdb-in-ram"
myconf="${myconf} `use_enable nls utf8`"
- if ! use tcltk; then
+ if ! use tcl; then
myconf="${myconf} --without-tcl"
fi
@@ -72,7 +72,7 @@ src_compile() {
emake doc || die
fi
- if use tcltk; then
+ if use tcl; then
cp -P ${FILESDIR}/maketcllib.sh ${S}
chmod +x ./maketcllib.sh
./maketcllib.sh
@@ -106,7 +106,7 @@ src_install () {
dohtml doc/*.html doc/*.txt doc/*.png
fi
- if use tcltk; then
+ if use tcl; then
mkdir ${D}/usr/$(get_libdir)/tclsqlite${PV}
cp ${S}/tclsqlite.so ${D}/usr/$(get_libdir)/tclsqlite${PV}/
cp ${S}/pkgIndex.tcl ${D}/usr/$(get_libdir)/tclsqlite${PV}/
diff --git a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
index ec690760f2a4..cae94012a507 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.7 2006/07/22 20:25:32 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.8 2006/07/28 19:28:30 cardoe Exp $
inherit eutils toolchain-funcs alternatives
@@ -12,10 +12,10 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ia64 ~mips ppc ~ppc-macos ppc64 ~sh sparc ~x86 ~x86-fbsd"
-IUSE="nls doc tcltk"
+IUSE="nls doc tcl"
DEPEND="doc? ( dev-lang/tcl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
@@ -27,8 +27,8 @@ src_unpack() {
ewarn "The userpriv feature must be enabled to run tests."
ewarn "The testsuite will be skipped."
fi
- if ! use tcltk; then
- ewarn "The tcltk useflag must be enabled to run tests."
+ if ! use tcl; then
+ ewarn "The tcl useflag must be enabled to run tests."
ewarn "The testsuite will be skipped."
fi
fi
@@ -61,7 +61,7 @@ src_compile() {
myconf="--enable-incore-db --enable-tempdb-in-ram"
myconf="${myconf} `use_enable nls utf8`"
- if ! use tcltk; then
+ if ! use tcl; then
myconf="${myconf} --without-tcl"
fi
@@ -72,7 +72,7 @@ src_compile() {
emake doc || die
fi
- if use tcltk; then
+ if use tcl; then
cp -P ${FILESDIR}/maketcllib.sh ${S}
chmod +x ./maketcllib.sh
./maketcllib.sh
@@ -80,7 +80,7 @@ src_compile() {
}
src_test() {
- if use tcltk ; then
+ if use tcl ; then
if has userpriv ${FEATURES} ; then
einfo "sqlite 2.x is known to have problems on 64 bit architectures"
einfo "if you observe segmentation faults please use 3.x instead"
@@ -106,7 +106,7 @@ src_install () {
dohtml doc/*.html doc/*.txt doc/*.png
fi
- if use tcltk; then
+ if use tcl; then
mkdir ${D}/usr/$(get_libdir)/tclsqlite${PV}
cp ${S}/tclsqlite.so ${D}/usr/$(get_libdir)/tclsqlite${PV}/
cp ${S}/pkgIndex.tcl ${D}/usr/$(get_libdir)/tclsqlite${PV}/
diff --git a/dev-db/sqlite/sqlite-3.3.4.ebuild b/dev-db/sqlite/sqlite-3.3.4.ebuild
index c27d95b42406..4dd85cd1cc70 100644
--- a/dev-db/sqlite/sqlite-3.3.4.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.4.ebuild,v 1.3 2006/05/06 20:46:32 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.4.ebuild,v 1.4 2006/07/28 19:28:30 cardoe Exp $
inherit eutils
@@ -11,11 +11,11 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz"
LICENSE="as-is"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
-IUSE="nothreadsafe doc tcltk debug"
+IUSE="nothreadsafe doc tcl debug"
DEPEND="virtual/libc
doc? ( dev-lang/tcl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
src_unpack() {
# test
@@ -24,8 +24,8 @@ src_unpack() {
ewarn "The userpriv feature must be enabled to run tests."
ewarn "The testsuite will not be run."
fi
- if ! use tcltk; then
- ewarn "The tcltk useflag must be enabled to run tests."
+ if ! use tcl; then
+ ewarn "The tcl useflag must be enabled to run tests."
ewarn "The testsuite will not be run."
fi
fi
@@ -60,7 +60,7 @@ src_compile() {
myconf="${myconf} --disable-threadsafe"
fi
- if ! use tcltk; then
+ if ! use tcl; then
myconf="${myconf} --disable-tcl"
fi
@@ -77,7 +77,7 @@ src_compile() {
}
src_test() {
- if use tcltk ; then
+ if use tcl ; then
if has userpriv ${FEATURES} ; then
cd ${S}
if use debug; then
diff --git a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
index 0564503b5024..e3c9354e81e1 100644
--- a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.8 2006/07/22 20:25:32 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.9 2006/07/28 19:28:30 cardoe Exp $
inherit eutils alternatives
@@ -11,11 +11,11 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz"
LICENSE="as-is"
SLOT="3"
KEYWORDS="~alpha ~amd64 arm ~hppa ia64 ~mips ppc ~ppc-macos ppc64 s390 sh sparc ~x86"
-IUSE="nothreadsafe doc tcltk debug"
+IUSE="nothreadsafe doc tcl debug"
DEPEND="virtual/libc
doc? ( dev-lang/tcl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
@@ -27,8 +27,8 @@ src_unpack() {
ewarn "The userpriv feature must be enabled to run tests."
ewarn "Testsuite will not be run."
fi
- if ! use tcltk; then
- ewarn "The tcltk useflag must be enabled to run tests."
+ if ! use tcl; then
+ ewarn "The tcl useflag must be enabled to run tests."
ewarn "Testsuite will not be run."
fi
fi
@@ -59,7 +59,7 @@ src_compile() {
myconf="${myconf} --disable-threadsafe"
fi
- if ! use tcltk; then
+ if ! use tcl; then
myconf="${myconf} --disable-tcl"
fi
@@ -76,7 +76,7 @@ src_compile() {
}
src_test() {
- if use tcltk ; then
+ if use tcl ; then
if has usepriv ${FEATURES} ; then
cd ${S}
if use debug; then
diff --git a/dev-db/sqlite/sqlite-3.3.5.ebuild b/dev-db/sqlite/sqlite-3.3.5.ebuild
index 4428b1ffaebb..69b41a1e74c1 100644
--- a/dev-db/sqlite/sqlite-3.3.5.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5.ebuild,v 1.5 2006/05/06 20:46:32 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5.ebuild,v 1.6 2006/07/28 19:28:30 cardoe Exp $
inherit eutils alternatives
@@ -11,11 +11,11 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz"
LICENSE="as-is"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
-IUSE="nothreadsafe doc tcltk debug"
+IUSE="nothreadsafe doc tcl debug"
DEPEND="virtual/libc
doc? ( dev-lang/tcl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
@@ -27,8 +27,8 @@ src_unpack() {
ewarn "The userpriv feature must be enabled to run tests."
ewarn "The testsuite will not be run.
fi
- if ! use tcltk; then
- ewarn "The tcltk useflag must be enabled to run tests."
+ if ! use tcl; then
+ ewarn "The tcl useflag must be enabled to run tests."
ewarn "The testsuite will not be run.
fi
fi
@@ -59,7 +59,7 @@ src_compile() {
myconf="${myconf} --disable-threadsafe"
fi
- if ! use tcltk; then
+ if ! use tcl; then
myconf="${myconf} --disable-tcl"
fi
@@ -76,7 +76,7 @@ src_compile() {
}
src_test() {
- if use tcltk ; then
+ if use tcl ; then
if has userpriv ${FEATURES} ; then
cd ${S}
if use debug; then
diff --git a/dev-db/sqlite/sqlite-3.3.6.ebuild b/dev-db/sqlite/sqlite-3.3.6.ebuild
index 5eaa3340c1ff..bae559019390 100644
--- a/dev-db/sqlite/sqlite-3.3.6.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.6.ebuild,v 1.2 2006/06/26 03:13:12 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.6.ebuild,v 1.3 2006/07/28 19:28:30 cardoe Exp $
inherit eutils alternatives
@@ -11,11 +11,11 @@ SRC_URI="http://www.sqlite.org/${P}.tar.gz"
LICENSE="as-is"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nothreadsafe doc tcltk debug"
+IUSE="nothreadsafe doc tcl debug"
DEPEND="virtual/libc
doc? ( dev-lang/tcl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
@@ -27,8 +27,8 @@ src_unpack() {
ewarn "The userpriv feature must be enabled to run tests."
ewarn "Testsuite will not be run."
fi
- if ! use tcltk; then
- ewarn "The tcltk useflag must be enabled to run tests."
+ if ! use tcl; then
+ ewarn "The tcl useflag must be enabled to run tests."
ewarn "Testsuite will not be run."
fi
fi
@@ -59,7 +59,7 @@ src_compile() {
myconf="${myconf} --disable-threadsafe"
fi
- if ! use tcltk; then
+ if ! use tcl; then
myconf="${myconf} --disable-tcl"
fi
@@ -76,7 +76,7 @@ src_compile() {
}
src_test() {
- if use tcltk ; then
+ if use tcl ; then
if has usepriv ${FEATURES} ; then
cd ${S}
if use debug; then