summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-11-16 02:48:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-11-16 02:48:18 +0000
commitda80bcb4d63abd7c55e619aaba6f12c6c9b5e8ee (patch)
tree9f87cdb97ac5e6c64d56679597521e22fa93de53 /dev-db
parentStable for HPPA (bug #198238). (diff)
downloadgentoo-2-da80bcb4d63abd7c55e619aaba6f12c6c9b5e8ee.tar.gz
gentoo-2-da80bcb4d63abd7c55e619aaba6f12c6c9b5e8ee.tar.bz2
gentoo-2-da80bcb4d63abd7c55e619aaba6f12c6c9b5e8ee.zip
Fix for bug #198988, DoS with InnoDB. Also fixes upstream TMPDIR bug 30287.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog8
-rw-r--r--dev-db/mysql/files/digest-mysql-5.0.44-r26
-rw-r--r--dev-db/mysql/mysql-5.0.44-r2.ebuild68
3 files changed, 81 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index f2c85d81de6f..f7a753ed0678 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.428 2007/11/08 13:08:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.429 2007/11/16 02:48:17 robbat2 Exp $
+
+*mysql-5.0.44-r2 (16 Nov 2007)
+
+ 16 Nov 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +mysql-5.0.44-r2.ebuild:
+ Fix for bug #198988, DoS with InnoDB. Also fixes upstream TMPDIR bug 30287.
08 Nov 2007; Raúl Porcel <armin76@gentoo.org> mysql-5.0.44-r1.ebuild:
alpha/ia64/x86 stable
diff --git a/dev-db/mysql/files/digest-mysql-5.0.44-r2 b/dev-db/mysql/files/digest-mysql-5.0.44-r2
new file mode 100644
index 000000000000..077600c7d9cf
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-5.0.44-r2
@@ -0,0 +1,6 @@
+MD5 a6a557758bfb66557a1182db75b46b2f mysql-5.0.44.tar.gz 24388270
+RMD160 7b380cf13d040149e5f0e75b582124ec996e0b03 mysql-5.0.44.tar.gz 24388270
+SHA256 e3cd455da52769cc7c80845992dedc9092745fcf3ea4d4929ae4181418805973 mysql-5.0.44.tar.gz 24388270
+MD5 ae44e04a104b8785fea0bea3176ba9b7 mysql-extras-20071115.tar.bz2 56027
+RMD160 5e57e4a81c5874f2a4bb0c685d52d8bd9dabdcfb mysql-extras-20071115.tar.bz2 56027
+SHA256 ec97e9147028448dc6d057744e80d2fd242b06796db8b19b9181d5f8acaafe7f mysql-extras-20071115.tar.bz2 56027
diff --git a/dev-db/mysql/mysql-5.0.44-r2.ebuild b/dev-db/mysql/mysql-5.0.44-r2.ebuild
new file mode 100644
index 000000000000..eabe7eb72c4e
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.44-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44-r2.ebuild,v 1.1 2007/11/16 02:48:17 robbat2 Exp $
+
+MY_EXTRAS_VER="20071115"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if ! hasq "userpriv" ${FEATURES} ; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream"
+ fi
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # mysqladmin start before dir creation
+ mkdir -p "${S}"/mysql-test/var{,/log}
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Broken in 5.0.42" ;;
+
+ 5.0.44)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+
+ 5.0.45)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+ esac
+
+ # We run the test protocols seperately
+ make -j1 test-ns force=--force
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force=--force
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt