summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-05-19 17:03:08 +0000
committerPeter Johanson <latexer@gentoo.org>2005-05-19 17:03:08 +0000
commitce883dcf3b6012885520bbed9f001a21edeb5a99 (patch)
tree5b24c89e36810e6a77861fb79c0f91fff7d70e79 /dev-dotnet/gtk-sharp
parentnew release (diff)
downloadgentoo-2-ce883dcf3b6012885520bbed9f001a21edeb5a99.tar.gz
gentoo-2-ce883dcf3b6012885520bbed9f001a21edeb5a99.tar.bz2
gentoo-2-ce883dcf3b6012885520bbed9f001a21edeb5a99.zip
Bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-dotnet/gtk-sharp')
-rw-r--r--dev-dotnet/gtk-sharp/ChangeLog7
-rw-r--r--dev-dotnet/gtk-sharp/Manifest2
-rw-r--r--dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.52
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-2.5.5.ebuild86
4 files changed, 96 insertions, 1 deletions
diff --git a/dev-dotnet/gtk-sharp/ChangeLog b/dev-dotnet/gtk-sharp/ChangeLog
index 425fc2d539c8..290e9b5b2b68 100644
--- a/dev-dotnet/gtk-sharp/ChangeLog
+++ b/dev-dotnet/gtk-sharp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/gtk-sharp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.34 2005/05/17 13:02:28 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.35 2005/05/19 17:01:20 latexer Exp $
+
+*gtk-sharp-2.5.5 (18 May 2005)
+
+ 18 May 2005; Peter Johanson <latexer@gentoo.org> +gtk-sharp-2.5.5.ebuild:
+ Bump.
17 May 2005; Peter Johanson <latexer@gentoo.org>
gtk-sharp-1.9.3-r1.ebuild, gtk-sharp-1.9.3.1.ebuild:
diff --git a/dev-dotnet/gtk-sharp/Manifest b/dev-dotnet/gtk-sharp/Manifest
index 73d74732ed06..bdc8323c7afd 100644
--- a/dev-dotnet/gtk-sharp/Manifest
+++ b/dev-dotnet/gtk-sharp/Manifest
@@ -6,6 +6,8 @@ MD5 e06909c47712ae995f4879eefb22e38b metadata.xml 160
MD5 c1d0f71cc8ab4f08784bdedc8bf1b896 gtk-sharp-1.9.3.ebuild 1383
MD5 c9267c734b06382e5fed5e270df3d9c8 gtk-sharp-1.9.3-r1.ebuild 2082
MD5 f47dc6805f7acab0d2f9d67322a52328 gtk-sharp-1.9.3.1.ebuild 2075
+MD5 4a23f82450dc1e1ef51f00273d0e142d gtk-sharp-2.5.5.ebuild 2127
+MD5 d3c03463afacd40a934397a076f9bf9b files/digest-gtk-sharp-2.5.5 147
MD5 ff5a2a47c3e1d785fc179c922857e409 files/digest-gtk-sharp-1.0.6 147
MD5 3af46f2e9fbd6a7f642bc1ef502d50ca files/digest-gtk-sharp-1.0.8 147
MD5 d1dddb54802e684259aedfd27a11af15 files/digest-gtk-sharp-1.9.2 147
diff --git a/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.5 b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.5
new file mode 100644
index 000000000000..ad834c5fdb01
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.5
@@ -0,0 +1,2 @@
+MD5 9ba5939aa604555a7c9eadbdcce44a52 gtk-sharp-2.5.5.tar.gz 2175385
+MD5 9cda427d7c40ed5fa33c39f623ad30b3 gtk-sharp-2.5.5-configurable.diff.gz 1466
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-2.5.5.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-2.5.5.ebuild
new file mode 100644
index 000000000000..c75a69ffbef2
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-2.5.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-2.5.5.ebuild,v 1.1 2005/05/19 17:01:20 latexer Exp $
+
+inherit eutils mono
+
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
+SRC_URI="http://go-mono.com/sources/${PN}-2.0/${P}.tar.gz
+ mirror://gentoo/${P}-configurable.diff.gz"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+IUSE="doc"
+
+RDEPEND=">=sys-apps/sed-4.0
+ >=dev-lang/mono-1.0
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/orbit-2.8.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~x86 ~ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${WORKDIR}/${P}-configurable.diff
+ #fixes support with pkgconfig-0.17, bug #92503
+ sed -i -e 's/\<PKG_PATH\>/GTK_SHARP_PKG_PATH/g' configure.in
+
+ export WANT_AUTOMAKE="1.8"
+ aclocal || die
+ automake || die
+ autoconf || die
+ libtoolize --copy --force
+
+ # disable building of samples (#16015)
+ sed -i -e "s:sample::" Makefile.in
+}
+
+src_compile() {
+
+ local myconf=""
+ # These are the same as from gtk-sharp-component.eclass
+ for package in art gda glade gnome gnomedb gnomevfs gtkhtml rsvg vte
+ do
+ myconf="${myconf} --disable-${package}"
+ done
+
+ econf ${myconf} || die "./configure failed"
+ LANG=C emake -j1 || die
+
+ if use doc && has_version dev-util/monodoc
+ then
+ cd ${S}/doc
+ emake -j1 assemble || die "Failed to generate docs"
+ fi
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/lib /gacdir /usr/lib /package ${PN}-2.0" \
+ DESTDIR=${D} install || die
+
+ dodoc README* ChangeLog
+
+ if use doc && has_version dev-util/monodoc
+ then
+ cd ${S}/doc
+ insinto $(monodoc --get-sourcesdir)
+ doins gtk-sharp-docs.{tree,zip}
+ fi
+}
+
+pkg_postinst() {
+ if use doc && ! has_version dev-util/monodoc
+ then
+ ewarn
+ ewarn "Although 'doc' is in the USE flag list, gtk-sharp will"
+ ewarn "not install its monodoc documentation unless you have monodoc"
+ ewarn "installed. If you want the documentation to be available in"
+ ewarn "monodoc, please emerge monodoc then re-emerge gtk-sharp."
+ fi
+}